Brave settings page does not respect dark theme when fingerprinting set to strict

Brave settings page does not respect dark theme when fingerprinting set to strict. It falls back to light theme.
Reverting the fingerprinting setting to standard works fine as expected.
Should retain the dark theme for settings page and blank home page.

  1. Go to settings page, set the theme to dark.
  2. Under shield settings change fingerprinting to strict
  3. Now move to other sections of the settings page and notice the theme will revert back to light color. Same issue on a blank home page, it turns the page pure white.

Expected result:
Should retain the dark theme for settings page and blank home page.

Brave Version( check About Brave):
Version 1.27.78 Chromium: 91.0.4472.114 (Official Build) beta (64-bit)

Additional Information:

Hey @saxekav563 ! Welcome to the community :smiley:

Are you referring to Brave Search settings? We use cookies to save your Search settings which setting fingerprinting to strict restricts. Unfortunately, there is not way around this.

If you are referring to in browser settings (brave://settings/appearance), those should not be affected by fingerprinting; only that some pages do not support dark theme yet.

Porridge

Sorry for not being clear earlier, I am referring to the Brave browser settings i.e. brave://settings/appearance.
It used to work just fine few days back, with the above mentioned beta version am noticing this issue…

The bug has been fixed.

The fix is scheduled to land in the 1.27.x milestone as of the moment.

2 Likes

Hello,

Brave Dev 1.27.x has the same issue. Brave Nightly 1.28.x is working ok.

dmf77.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.