Brave seems to have a compatibility issue with Apple Discussions webpages

There appears to be a compatibility issue with Brave and Apple Discussions webpages (

I almost always see error messages that prevent posting (and seem to make no sense), which doesn’t happen if done in Chrome (i.e, messages post normally).

Brave browser v. 1.21.73
OS Mojave 10.14.3

What error message are you receiving? Does shields settings affect it?

@fanboynz These two most recently, particularly the first one:

“Your session has expired. Please log in again to restore your reply.” (Logging in again has no effect. Same error message.)


“Your post could not be saved. Please try again in a few moments.”

I haven’t tried disabling shields. Which of the five shields settings would you suggest I turn off – any one of them in particular or ‘all’?


Usually, I start off allowing all cookies first, then turning off fingerprinting, then I disable shields completely. At the last step I always report the site as broken even if disabling shields works…

1 Like

@megaspaz Thanks, just had an opportunity to test it (before seeing your post) and its the shields all right. I just turned them all off. Then no problem.

Next time I’ll try your steps.
. . . . . . . . . . . … . . . . … . . . . … . . . . … . . . . … . . . . … . . . . … . . . . … . . . . … . . . . … . . . . … . . . .
UPDATE . . . Looks like I have to revise that. It just happened again, this time with all shields down.


Screenshot of the issue? and exact steps to reproduce?

@fanboynz Just tried two ‘test’ posts at

Both went through normally.

This phoenix is sure to rise again.

When it does, I’ll post the screenshot.

(All a screenshot will show is an attempted post in one of Apple’s discussion forums and the error message;

"Your session has expired. Please log in again to restore your question."

Logging in again just leads to the same error message repeating when the ‘submit’ button is pressed for a new (or reply) post.

That said, I’m seeing feedback about this issue in the same Apple forum suggesting that it’s not specific to Brave, as there are claims that it’s also occurring in Firefox and Safari. However, for what it’s worth, so far I have not experienced it at all in Chrome.)

Good to see it working

Sessions are often cookie related, try clearing the cookies/cache, then relogin.

Also tab inactivity may cause session expirying, depending on the site, it’ll timeout after x mins if no post/mouse detection/general inactivity. Also changing/login a VPN could reset the session.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.