Brave seems to be igoring my .hosts file settings

Description of the issue:
Brave is not following my .hosts redirect. I have set up a local WAMP server and created a virtual host to point a specific url to that project. Brave is ignoring that.

How can this issue be reproduced?

  1. edit your .hosts file with redirect (my example is both wordpress.local and wp.com)
  2. go to desired url
  3. you will be on the wrong page (for wordpress.local I get a search result, for wp.com it goes to that actual domain instead of my redirect)

Expected result:
I should be routed to my local folder (this works on firefox and chrome so I know it is a brave specific issue)

Brave Version( check About Brave):
Version 1.42.97 Chromium: 104.0.5112.102 (Official Build)

Additional Information:
None

1 Like

What file path, exactly, are you modifying?

Also, just to confirm that the OS tag here is correct, this is on Windows right?

What do you have the Use secure DNS setting in Brave set to? I’m not sure if enabling this bypasses local hosts lookup, but if toggling that doesn’t change anything I can do some testing on my end.

1 Like

The file path to my hosts file> (it is a good location, as I said, the changes work for Firefox and chrome)

It is in this directory
C:\Windows\System32\drivers\etc\

I have applied the change
127.0.0.1 wordpress.local
127.0.0.1 wp.com

I am on
Windows 10 Pro
21H1

Secure DNS was set to “with current provider” I have also tried switching it off but it is currently on, and “always use secure connections” is off

In testing today to reply to your query, my error switched from loading the real “wp.com” page to a “This site can’t be reached” with a “ERR_CONNECTION_REFUSED” message. I assume the first was a delay in DNS flush on Brave, but it is still not loading

Seems similar to this issue? Linux Brave fails on LAN site - #3 by JimB1

In which case my comments would be similar. :slight_smile: Haven’t seen any follow-up on that thread yet but maybe we can get somewhere here.

To clarify, are you saying the ERR_CONNECTION_REFUSED occurred when Secure DNS was disabled? Or enabled? It would probably be best to leave it disabled until we get this figured out.

1 Like

I found the issue with your help, thanks!

Under “Security” there is “Always use secure connections”, I had this toggled off
What I didn’t know was under “Shields” there is also “Upgrade connections to HTTPS”, this was on, I toggled it off and the redirect is now working properly

Question, is the Shields and Security supposed to do the same thing, or is there one that I should toggle back? Did I discover a duplicate setting that will conflict with another setting?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.