Brave says Uphold Wallet isn't verified, Uphold says it is

Briefly describe your issue:

As my title says, my uphold account says that my identity is verified, but Brave browser does not agree. This is true on two different computers and my iPhone. I haven’t received BAT rewards since December 2021 as a result even though I’ve been receiving ads. Anybody have a solution?

What Operating System and Brave version are you using (Menu --> About Brave)?
Mac OS 10.13.6 and Brave Version 1.34.80

Is your browser wallet currently verified? (yes/no)
Yes, but see title.

What date did you verify your wallet?
12/28/2020

Have you been able to successfully receive payments in the past?
Yes

Are you using a VPN? (yes/no)
No

Are you in a supported region (see here for list of supported regions)?
Yes. USA-Minnesota

Does your device pass the SafteyNet check (Android only)?
N/A

Have you fully completed Uphold’s CDD requirements?
Yes.


Hi and welcome to the community. :slightly_smiling_face:

You should probably update to the latest Brave version. There have been several issues and fixes which may fix your problem once you update. I do not know if your OS is updated but you should update to the latest OS version too if one is available.

You cannot connect to a custodial account on iOS devices per Apple policies.
Brave Complies With Apple iOS Guidelines, Will Continue to Innovate for Users and Creators They Support

1 Like

Thanks for the reply. Upon updating my browser, I got a notice saying my rewards account has been flagged. Is there anything I can do about that or am I SOL until the Brave team eventually gets to me?

I am having the exact same issue. I have an android phone that’s saying this. Uphold says it’s good, brave says no. I’ve disconnected it via uphold, reconnected it and it says “Something went wrong please try again.” But when you look in uphold it’s connected and even shows the few minutes before when it is active. There isn’t anything to update either as it’s the latest version.

You can DM a moderator for help. In the meantime, here is a form you can fill out that may help expedite your issue.

1 Like

Try deleting the uphold app from your device. Then try verifying through Brave again. It will re-direct you to the uphold web page. That usually solves the problem.

2 Likes

Thanks for your help.

1 Like

Did that fix your issue?

No, first I went into uphold and removed the brave browser from integration, uninstalled it / rebooted my phone then reinstalled uphold. Once I got into brave I tried to reconnect it and it started uphold. At the top it said error “Something went wrong. Please try again.” as it did before. I checked the integration, and uphold shows brave browser connected so it is connected. However, Brave itself says unverified. I’ve tried cleaning out the cache and all the normal procedures. I think it might have something to do with the 4 device limit. I’ll have to wait until the people can get those old devices removed from my account and try it again. But I appreciate the help. If I find a fix I’ll be sure to post it.

BEST THING TO DO IS DELETE THE UPHOLD APP! Delete it, reauthorise through brave browser should redirect you to uphold.com, viola! It’s authorised and can download the app again!

If it is in fact device limit, this link will help you address that issue.

1 Like

Yeah that’s exactly what I did. Completely deleted it and ran a cache cleaner / rebooted. No luck.

Yeah earlier today I did all of that and submit my request.

1 Like

That’s strange. Worked perfectly fine for me on all 3 of my devices - android.

Once I deleted the app, o went to verify wallet on the bat rewards pop-out, it redirected me to uphold.com, clicked authorise and it worked, maybe clearing the cache could be the reason it wouldn’t connect? Random I know, but known to happen , but just because it worked for me doesn’t mean it will for everyone unfortunately.

2 Likes

That’s alright, with all the different hardware I’m not surprised. It’ll sort out eventually. It’s showing in uphold just fine, so it is working. Brave just shows “unverified”. Every thing is working fine except that, which is why I’m thinking it’s the device limit causing the issue. Brave still takes me into uphold and everything just fine. I do appreciate the suggestions and help. I’m dealing with an infected tooth at the moment so I’m having trouble concentrating. Sometimes doing nothing fixes problems, so I’ll just be patient and wait. After I get a nap I might mess around with it again. I’ll be sure to post the steps If I do get it fixed. Have a good night you guys.

1 Like

If you go to brave://rewards-internals, does it show your wallet ID? DON’T POST IT