Brave Rewards Screen Is Blank

**Briefly describe your issue:**Maybe it’s me, but my rewards screen is blank, as well as #verify. I tried to untether from Uphold as a fix. Can’t reconnect.

**What Operating System and Brave version are you using (Menu --> About Brave)?**Android 11; Build/RKQ1.210420.001
Brave 1.37.112, Chromium 100.0.4896.79

**Is your browser wallet currently verified? (yes/no)**no

**What date did you verify your wallet?**April 06, 2022

**Have you been able to successfully receive payments in the past?**Yes. I received monthly payments from Brave. My 1st transfer to Uphold went thru on Apr 8.

**Are you using a VPN? (yes/no)**No

**Are you in a supported region (see here for list of supported regions)?**Yes

**Does your device pass the SafteyNet check (Android only)?**Yes

**Have you fully completed Uphold’s CDD requirements?**Yes. I have full access to my Uphold account.

The blank Rewards screen is a known issue. Posted the link to the Brave GitHub issue report below. Appears the fix will be released in the next version update.

Rewards page blank with devtools errors

As for not being able to reconnect with Uphold, that is probably due to the current payout issues that Brave dev is actively working on at the moment. However, you may want to try the steps below, this was a workaround that was successful for many users in the past. May still work for you. You didn’t say if you were receiving a message when you tried to reconnect. Most users were receiving a “Something Went Wrong” type message in this scenario.

Cannot Connect Brave Rewards with Uphold Account

Release Channel 1.37.114

1 Like

I assume there will be an update to resolve?
I’m not seeing an Android tag on the thread you posted.
Also I just received my April BAT, again. Same amount as the April payout, 8.75. I claimed it as i thought maybe the issue was resolving and maybe i would get a zero amount.
And last, when I tap on the “i” next to “brave://rewards” and select “details”, the certificate information link is unresponsive.

Yes, that update is already available on desktop. Android should also be available soon. Not sure how long it typically takes to update the releases for Android after they post here. You might can get an estimated release date based on your experience?

So they are processing the claim again? In other words, you received the payout and are now receiving another one for the same amount? I had a claim button on the “triangle” panel but not in brave://rewards. When I clicked it, it just disappeared. I assumed it was just an artifact since I didn’t get a puzzle to solve or any other notice after I clicked it. Is your experience different?

I don’t understand what this is. I only use desktop and do not have an “i” anywhere. Is this something for mobile devices? Can you provide a screenshot?

There was an update. I updated and the problem persists.

There is the “i” i was referring to.
The double payment is in my balance on the browser, 8.75 BAT. I still can’t reconnect to uphold.

Did you try clearing history/cache, exiting brave, and reopening? I did that on desktop after your post #4 and claim button was in brave://rewards. You might want to see if that works on your mobile if you haven’t already tried. :smiley:

Also, have you tried this workaround for linking to Uphold?
Cannot Connect Brave Rewards with Uphold Account

I’ve tried everything I can short of re-installing, I believe. I feel this problem began after I cleared the cache following the 1st update, the whole blank screen issue with brave://rewards and brave://rewards/#verify.


Did the new update only solve the issue (blank reward page) on desktop only? If so, will the same update be taken for android in few days? Or the update was only for desktop and nothing to do with android.

There is a user with same problem but on android and not on desktop.

@chh_68 I think the update is for desktop and android. I don’t know how long it usually takes after the desktop version is released to get the android update. Any ideas?

I also thought payouts could still be processed even if the screen is blank (read a post from Mattches but can’t find atm) but if @CShells00 is unable to connect to Uphold, that isn’t going to matter much.

@CShells00 You could wait until the current version is released for android or you could tag the moderators or DM them with your wallet payment id found at brave://rewards-internals and see if they have more information. Don’t post your wallet id!

You could also try installing Beta and/or Nightly version and see if the problem persists in those versions or not. At lease would give you some idea if a fix is going to be forthcoming.

1 Like

Good question — I think it’s going to hit desktop first before Android. I’m working on getting the Android issue prioritized as we speak.


I’ve installed Nightly. It works fine.

I’ll wait a while and look for an update. If there isn’t a resolution after then I’ll look into contacting the moderators.
Thank you for the focus and diligence on these matters. Much appreciated.


I’m guessing i check the solution box if its been resolved? Do i check them all? I don’t know the decorum around here.
I had to delete the uphold app to re-verify. Used the website and logged into it through the rewards page. Nice work and thank you!

I should add that the update resolved this.

@CShells00 You just have to click one solution. I don’t think you can click more than one. If you click another, it will just unclick the previous (if that makes sense!).

So happy that your issue was solved with the update! :smiley:

And thank-you for indicating your topic was solved and for posting exactly what solved the issue! So nice to see how and why an issue has been solved. Really helps other community members - both those trying to help and others who may be experiencing the same problem.

1 Like

@Chocoholic I will also add that i had to delete the integration on Uphold before i could re-verify. Might be good to know for anyone having issues there.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.