Brave rewards not working on (Linux) desktop browser, but ads still showing

Briefly describe your issue:
Rewards have been working for me in the past. The triangle icon seems to have a timeout between clicks. When it works and the dialog shows, all the totals are zero except for the Expected earnings, as shown here:

Clicking on either the “Unverified>” button or the settings cog icon takes me to the brave://rewards screen and the “Start using Brave Rewards” button. Clicking the button does nothing except animating the click with the fade animation.

I first noticed some problems a few weeks ago. The “Unverified>” button took me to a dialog with buttons to connect to Uphold or Gemini. My account is verified with Gemini, but clicking either of these buttons did nothing (except animate the click). Now that page doesn’t even show.

I’ve tried both with and without my VPN activated and it makes no difference. Any attempt to select settings or verification just goes back to the page with the “Start using Brave Rewards” button. I see no errors or warnings.

I also use Brave (with Brave Rewards activated) on my Android mobile. That is all working and correctly linked to my Gemini account.

I hope it’s going to be possible to recover my BAT and re-establish the link to my Gemini account.

What Operating System and Brave version are you using (Menu --> About Brave)?
Linux Mint 20.1 Ulyssa
Brave: Version 1.45.114 Chromium: 107.0.5304.68 (Official Build) (64-bit)

Is your browser wallet currently verified? (yes/no)
Yes (Gemini)

What date did you verify your wallet?
5th November 2021

Have you been able to successfully receive payments in the past?

Are you using a VPN? (yes/no)
Yes, but tried with it deactivated. No difference either way.

Are you in a supported region (see here for list of supported regions)?
Yes (UK)

Does your device pass the SafteyNet check (Android only)?
My Android installation is working fine, it’s only a problem with the desktop.

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??
I’m using Gemini, not Uphold, but no auto-contributions are (were) active.

So you can’t even try to connect to Gemini?
@SaltyBanana @steeven please look into this.

Hi @Spuggiehawk , welcome back to Community!

Thanks for bringing this to our attention. I’ll reach out to our team for more information.

In the meantime, could you kindly submit a ticket to our Support form(DM me the ticket number) and include a link to this original post and a screenshot of your General Info tab and Events tab found by going to brave://rewards-internals
From there we can take a closer look at the matter.


Hi @Spuggiehawk

Are you in a supported region (see here for list of supported regions)?
Yes (UK)

I just looked over your post again and I notice you stated you’re in the UK and you are connecting a Gemini account?
At this time, Gemini accounts that are outside of the United States are not supported. You will still be able to log in to your Gemini account and receive your payout as long you are not disconnected.
You can learn more below:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.