Brave resolution issues in Windows 10. Blurry application constantly

Hmm, I wonder if you’re encountering this issue:

1 Like

Thanks for that link. Yes this seems very similar.
It looks like this issue is open for almost a year now. Has there been any progress?
I really would like to point out that this is not just a design issue. Battling those blurry fonts all day causes literally headaches and eye strain.


Let me reach out to some team members and see if I can get a status update on the issue. It’s a very busy day today so it may take a while.

I do appreciate your patience.

1 Like

Thanks. I appreciate it.

1 Like

Can you also try with a new profile (Menu --> Create new profile) and see if you get the same results? I’m wondering if one of your installed extensions is causing the issue – easiest way to test against this is to create a new profile which won’t have those extensions enabled (as opposed to disabling them all individually).

Additionally, would you be willing to launch Chrome and see if you get crisp/clear text on Chrome the way you do in Edge?


Thanks for your suggestions which I tried.
But let me tell you it is not a matter of extensions.
The blurriness issue exists from day 1 I start using the Brave Browser. In fact the first extension that I have installed was Chrome Font Rendering Enhancer. I think this says it all.
Now my findings: I tried Chrome without extensions and it is also blurry. Same as said with Brave Browser.
Can I ask you in return to try for yourself with Edge? I don’t know if you are aware that the new Edge is also based on Chromium, so in theory if Edge can do better, Brave Browser and Chrome should be able to do better as well:

I am attaching new images from the website, displayed with Brave, Chrome and Edge all of them with same zoom settings and screenshot with the same application.
You can clearly see the fonts display in Edge is much better but it is not just the websites font, it is the entire application.

Not too sure about what’s causing this, still digging.
Did you try creating a new profile to test?

Yes. I have tried and it is as blurry as before.

1 Like

I’m also seeing this issue. I’ve tried all the steps above but nothing really helps. This happens on Chrome 83 and Brave 1.9.76 (chrome 81)

1 Like

Keeping this thread alive. :roll_eyes:

1 Like

Do you have a “large” monitor? Like 2k or 4k?
Mine is 2k and to avoid programs beeing blurred I used this tool:

You should check the Windows 8.1 DPI Scaling. I keep the scaling at 125%.
No blurry apps so far.

Don’t know if this could help tho ¯\_(ツ)_/¯

Thanks for your suggestions.
I don’t use such a large monitor.
But even if: The problem is, that the blurriness shows on the same machine where Microsoft Edge does not show it.
So if it would be a monitor or DPI issue, shouldn’t Microsoft Chromium Edge show the same blurriness?
Or the other way around: Shouldn’t Chrome or Brave be able to display fonts as sharply as Chromium Edge?
I have 2 monitors. Just right now Chromium Edge runs on the left, Brave on the right. Whenever my eyes switch from Edge to Brave it literally hurts in my eyes because they have to adapt to this blurry mess in Brave. It is very very uncomfortable.

What type of video card do you have? I have an Nvidia GTX 1060. I too had a similar problem and found the solution in the Nvidia control panel. It is a while back now, but iirc, it had to do with changing how Nvidia handles the app (Brave) in the control panel. Drill down deep into your control panel, assuming you have an Nvidia card. Keep an eye out for Edge settings. You will want to duplicate the settings for Edge. Good luck!

Yesterday I installed only ( not drivers) the NVIDIA Experience graphics card extension and today I noticed blur font. that was the only change since yesterday so I suspect that was it. I disabled hardware Acceleration and the problem is gone :slight_smile:
it may be useful to someone to identify the source of the problem

Well I keep thinking that on the same computer where Edge Chromium manages to display sharp fonts, Brave, built on the very same foundation, should be able to do so as well.

Try this with Windows 10…
Go to Setting.
Type performance in the Find a setting box.
When Adjust the appearance and performance of Windows appears, select it.
Make sure the boxes for Smooth edges of screen fonts and Smooth-scroll list boxes are checked.
Not sure why this only affects Brave browser, but on my machine, when they are un-checked, the font gets blurry in the Brave browser.

1 Like

In Brave:

Settings > Additional Settings > System

Turn off Hardware Acceleration when available.

Let me know if that fixed it for you because it did for me.


Thanks for your suggestion but playing with that setting was the first thing I did and it does not change the bluriness no matter what it is set to.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.