Brave pushes Disqus to log into one of my accounts

@Mattches

Hi there,

How are you doing?

Ok, so I’ve had this problem for a while & I forgot to mention it.

You know Disqus the commenting software that unfortunately MOST sites use? LOL

I can’t believe that they are the only game in town.

Anyway, I have about 4 different accounts for Disqus, & every time I go to log in, it pushes the login to just one of my accounts.

At first I thought it was Last Pass auto logging me in, but that can’t be it b/c the auto login is turned off on LP & it doesn’t even recognize the popup (that’s how you log in) initially b/c it’s focused on the main site that Disqus is on.

I hope you understood what I meant.

Anyway, I have tried it on Chrome & it doesn’t do that. Chrome allows me to choose which account I want to log in with even though it does initially auto-fill that same account that Brave is forcing the auto-login with.

I did do a screen recording, but then that would show you my e-mail address as the user name & I don’t want everyone to see it, so can I PM it to you?

Thanks

P.S. And on this page I can’t even log in at all. The popup opens & then closes without doing anything. I was trying it on a different Brave profile though, but that shouldn’t matter.

@OurFreeSociety,
Try visiting the Disqus website and logging in there, but make sure you change the cookie setting in the Shields panel for the site to All cookies allowed. Then see if you’re able to stay logged in/comment using your Disqus account.

For the site you linked at the bottom, are your Shields set to their default state? I ask because when I visit the site and click the Disqus icon to login, the pop-up appears as intended:

Hi there,

Well going to the Disqus site won’t help b/c they don’t use a popup to log in. It’s the normal login just like on most sites.

I can’t stand that so many sites have switched to popups for logging in.

Just like many sites now are taking away the scrollbar & I’m freaking out over that as I have no scrollbar on my ergonomic mouse.

Web designers are RUINING sites.

(end of rant).

And yes, my shields are always at the default b/c I really have no idea how the shields work LOL

You can log in b/c the Disqus site doesn’t use popups & you probably only have one login I’m assuming.

It just happened to me again & this time it doesn’t even keep me logged in. Every time I open a new tab it needs me to log in again. sigh

That’s on https://www.bitchute.com/channel/PwuzxHtoe7Eo/ but it’s the same issue on any site that uses Disqus like this one too - https://thefreethoughtproject.com/

Thanks

@OurFreeSociety,
Can you try opening the Shields panel inside the pop-up window prompting you to login and change the cookie control setting to All cookies allowed? We had a similar issue with other websites that used the pop-up login you so despise that was resolved in this way.

Sorry for the delay @Mattches

So I just spent at least 15-25 mins. doing what Disqus (yes I wrote them) told me to do except I didn’t try it on another browser.

Here’s a video again showing you what happens.

https://mega.nz/#!4hMAiaJb!e7eS1YZpIdduNe_Z62mZ0UpQBZ68BIOHw3M1eyjwGNY

I did turn on allow all cookies under that cross browser area of the shields.

I even turned off ALL of my extensions.

I also deleted the cookies which did initially help, b/c that allowed me to auto log in, but then it doesn’t actually log in. sigh

Here’s the article I was trying to log in from.

And I JUST tried it on Chrome & while I was already logged in, I logged out & then back in & it allowed me to choose what profile & logged me in with no issues.

Oh, & on Brave, I had also gone to the Disqus site & was already logged into that user.

So this is definitely Brave.

Thanks

@OurFreeSociety,
Thank you for the detailed reports. So I did some testing and it looks like I can reproduce this on my end, but only on Windows OS. The strange thing is that when I do visit the site you sent and try to login (using the same login option you used – right above the comments), it looks like it logs me in, but it doesn’t actually register.

In fact, when I click the little “comment bubble” next to the Login: image, then click Log in or Sign up on the next page:

:point_up: When I click that button, it takes me to the Disqus site, where I find that I’m already logged in.

Can you do me a favor and try visiting the site geeksforgeeks.org (this site also uses Disqus) and try logging in in that same way and see if you get the same results? I was able to login this way on that site (unlike when I was on wakingtimes).

Hi there,

Yeh that one worked for me too.

I don’t care about mobile as I hate mobile with a passion, so I’m on Win 7. I thought you knew that :slight_smile:

So what does that mean?

Again, it does work on Chrome. I didn’t test it on Fx.

And what you experienced with having to log on every page even though you were already logged in happens to me on bitchute.com

@OurFreeSociety,
I think it means there’s a web compatibility issue with the waking times website specifically. Can we try another test site? I was able to login normally using my Disqus account on androidcommunity.com – can you try as well? I’m going to reach out to some web-compat guys and see if I can get their eyes on the problem.

I did not have this issue on Bitchute – I seemed to be able to login only one time and stay logged in as I browsed the website.

@Mattches - sorry for the delay. I’m just very busy right now.

So I went to the android site & it didn’t let me choose which account to log in with.

To be clear about bitchute. I’m talking about when I reply to someone’s comment, video, etc. You won’t know unless you actually go & comment/reply. Maybe you are, but you didn’t mention that so I’m just confirming :slight_smile:

Thanks, & I hope you are doing well.

P.S. I just posted something in the rewards area.

Can I tag you there b/c I’ve written there before & I don’t think (I can’t be certain) I never got any responses back.

Thanks

1 Like

@OurFreeSociety,
Yes – feel free to tag me in any thread you think I would be useful in!
Also, for this disqus issue, I"m going to rope in a team member who may know more about this than I do.

cc @fanboynz for assistance

1 Like

Thanks @Mattches

I am forced to type 20 characters here.

Okay, have pushed out a fix for wakingtimes, give it 24-48hrs.

1 Like

@Mattches - sorry to cross post about this, but I didn’t want to create a new thread.

I wrote a long thread a few hours ago about Uphold & it’s been held up for moderation.

Can you clear it for me?

Thanks

Hi there,

So I just tried it & initially when I went to like a comment it asked me to log in, I filled everything out including the captcha, but then it didn’t log me in.

I then tried over & over & it won’t log me in. Just flips the popup & does nothing.

Here’s a video - https://mega.nz/#!010DXKiR!SwS2cmSPjzIpAKT8EPMidQ7zkwjykvy_DLW8xDo9ECA

Thanks

rolled out a new fix, should be out in the next 24-48hrs.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.