Brave prevents my screen from shutting down and my phone from sleeping


#1

Hello, first of all, my native language and my smartphone language are french so some of the terms may not be the right ones.

I’m using a Samsung S7 with Android 7.0

And since around the last update 14 June 2017, everytime I’m using Brave and when the app is in the foreground (active), it prevents my screen from shutting down (I set it to shut down after 30 sec).

Consequently, it also prevents my phone from locking and going to sleep mode (which I set after 1 minute of inactivity) as long as Brave is active on my screen.

Does anyone else has the same issue? Is it a new feature of Brave? If not, how do I prevents Brave from doing it?

Thank you well.


#2

Hi @Minhasty,

Thanks for reporting. And can you tell us what Brave version are you on?
cc @Serg for confirmation regarding this issue.


#3

Hi @eljuno,
My Brave version is 1.0.23


#4

@eljuno,

I have some new informations after some others tests :slight_smile:

Apparently, this only concerns a certain website, precisely, the webnovel reading website “wuxiaworld”. They may have change something in their code as their website keeps my screen from shutting down and my phone from locking.

So Brave is not necessarily responsible for my issue.

However, is it possible for a website doing that?

Thanks


#5

@Minhasty probably it is, especially when they have some kind of an endless loop that executes some JavaScript code all the time. You can try turn off JavaScript there and check does it happen that way or not. Thanks.


#6

@Serg,

Ok, I confirm that the issue lies in their Javascript as you said :weary:

Ok thank you for your assistance.

Case closed :smiley:


#7

@Minhasty great!. Would you mind to update a review on play store you left? Thanks.


#8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.