Brave performance on Macos has become unusable


Description of the issue:
How can this issue be reproduced?

  1. Load any page.
  2. Scroll, or enter data on text fields, or do anything.
  3. Periodically the Brave Browser Helper will take 100% cpu and a “beach ball” is displayed.
  4. In the course of entering this issue, it has happened 4 times, with the browser becoming unresponsive to text entry, scrolling, any interaction for 15-25 seconds.

This is not loading a page or using the network at all. Well, I guess with this page it is doing all sorts of fancy network access. But this occurs on other pages that are completely static. Closing a tab can result in a hang.

Expected result:
Do not peg the CPU and become unresponsive.

Brave Version( check About Brave):
Brave is up to date
Version 1.1.23 Chromium: 79.0.3945.88 (Official Build) (64-bit)

Additional Information:
notresponding macspecs

Install of Chrome on the same machine does not exhibit this behavior.

I’ve uninstalled Brave on all devices, and reinstalled, and the behavior is the same on all MacOS installs.

Hi, for me disabling hardware acceleration improved performance a lot in Brave on macOS. Did you try that already?

No, after have this happen consistently over a number of weeks, I uninstalled Brave

@publicmarvin,
Disabling Hardware Acceleration is likely to resolve the issue. The issue isn’t inheritly with macOS/Brave – I’m currently (as I’m writing this) running Brave Nightly, Dev and Stable with several tabs open in each without any issue.

I’m uncertain what the problem is but (as I write this with Chrome) Brave continues to be unusable with repeated delays and hangs. The Brave instance in question did have 16 tabs when I reopened, but that is quite normal for me, and had no issue with Brave some weeks ago. I upgraded to Brave.latest this morning and was able to (painfully) toggle the setting to disable ‘Hardware acceleration’. Restarting Brave immediately hung.


I really like Brave, it’s idea, and its chrome-ness without being google. (Personally I’d still like some server provided sync as a built-in option – I’m not a complete privacy zealot.) But this issue prevents me from using it. I apologize for not providing better feedback to understand the issue, but I see this behavior on three different Macs in two different network environments. And my job isn’t (and I don’t have time these days) to debug brave.

Just a couple more bits.

Two things coming to my mind:

a) when re-installing: did you remove all preferences / other files used by Brave? e.g. use an app like AppCleaner to remove all leftovers from a previous installation, see https://freemacsoft.net/appcleaner/

b) can you try without any extensions installed / enabled?

This is just a random guess but both had consequences for me on previous issues… so it might be worth a quick shot.

To sum up: un-install via AppCleaner, maybe even reboot, install a fresh version and do not install any extension, do not change any settings and try for a couple hours to see if the problem is gone…

1 Like

@publicmarvin,
You may also want to try creating a fresh browser profile and see if using it produces the same behavior. It may be something in the cache/browsing data the browser is trying to load or use that’s causing the conflict.

1 Like

I have the problem on Ubuntu and disabling hardware acceleration does NOT solve the problem. I think at this point the Devs think that’s a workaround, and it’s NOT.
I’m ready to go to Firefox since it’s been a month or so - ever since 1.1.20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.