Brave opens new window and correct link when opening external links

Description of the issue: Beginning yesterday, when opening Brave, two windows are launched. When clicking a link from another program, the correct webpage opens in one browser window but another new window is opened that displays the new tab page.

How can this issue be reproduced?

  1. Open Brave Web Browser.
  2. Notice that two browsers windows are created when only one is expected.

OR

  1. Click a link from another application on your computer.
  2. Notice the correct link is opened and a blank browser window also is opened.

Expected result: When clicking a link, the correct page opens. A blank window does not open as well.

Brave Version: Version 1.14.84 Chromium: 85.0.4183.121 (Official Build) (64-bit) - LINUX

Additional Information: The blank, unneeded window opens on top of the expected window. Extensions installed: Bitwarden and TickTick. Computer OS: elementary OS 5.1.7. Ubuntu 18.04.4. Linux kernel 5.8.9-050809-generic. Computer restart did not fix the issue. No OS/kernel updates have been performed recently.

@patrickdemers6,
Thank you for reaching out to us.
Do you by chance have more than one browser profile created?

Hi @Mattches, I managed to resolve the issue for now by using xkill and clearing my browser cache. I’m not sure which one did it or if the solution is permanent but for now, my problem is resolved. Brave is awesome, thanks for your hard work.

1 Like

a) In Settings, is On startup set to Open a specific page or set of pages? This can be a cause.

b) Disable Extensions and test … on occasion, a misbehaving extension can cause odd behavior.

c) Rogue Brave process still running. You’ve exited Brave, but a rogue Brave process has been left running. Then the next time you fire up Brave, the rogue Brave appears. In the future, exit Brave, then run “ps” to see if a process is still running.

It seems ( c) might have been your issue, as you ran kill to stop all Brave processes.

1 Like

@patrickdemers6,
Happy to hear you got the issue resolved – great work!
And thank you for the kind words! :heart: