Brave Opening in Regular Tab of Background Window Instead of Active Incognito Window

I’ve been using Alfred workflows on my Mac to open various URLs and Queries in Brave. For example, in one script, I run,

open -a "Brave Browser" "$url" 

In another script, I run the Default Web Search workflow:

These, until recently, would open in my active incognito window, but in the last week or two have been opening instead in my background non-incognito window.

Has there been a recent change to affect this? Is there a setting I can change? Why has this stopped working properly?

Version 1.57.47 Chromium: 116.0.5845.96 (Official Build) (arm64)
MacBook Air, M1, 2020

Just wanted to let you know I am in the same boat.

I’ve tried in both Brave and Google Chrome (most recent versions) and they’ve both demonstrated this new, undesired behavior. It must be Chromium-related.

That’s for replying.

I couldn’t find a Brave setting for this, but altering the open command worked for me.

open -na "Brave Browser" --args -incognito "$url" # opens in incognito tab

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.