Brave only works with v.0.18.23.0 and upon updating, brave refuses to open. please help. I havent been able to use brave in 8 months because of this issue


#1

So my issue actually started about 8 months ago and i have not been able to use Brave since then and i cant seem to get any help with my issue. It worked fine when i first started to use it, but then one day when i tried to open it, the icon appeared on the tool bar, but it wouldnt open. If i hover over the icon, i can see the preview window with the last page i visited in the preview, but nothing happens when i try to open it. For awhile i thought it was opening off screen, but i dont think that is the case.

Fast forward to today, i attempted to reinstall it on the oldest installer of brave that i had, and eureka! it worked! HOWEVER, now it prompts me to update brave and upon updating it, it went back to the problem of acting like its working, but wont open no matter what i do. To fix this, all i need to do is reinstall the oldest installer i have on my machine (file version: 0.18.23.0)

but after trying to fix the issue again, now my temporary fix doesnt work and even with the older version installed, the window will open for a split second, then disappears. at first it would load the page, but after a couple of tries, it wont even load it before killing it.

How do i fix this issue? i really want to use brave, but brave doesnt like me apparently.

I have never had a problem like this with any other browser, on any other machine.


#2

Hi @tyrantt, Sorry to hear about your troubles!

What operating system are you using? Have you tried a clean install (you can find instructions for that here)?