Brave only works on a single RDP session

Brave will not run in multiple RDP sessions for the same user.

Scenario:
Session #1: You are logged into a server using RDP and you are running Brave.
Session #2: You connect a second session on the same server as the same user, you cannot start Brave. It will not start.
You can have other people logged onto the same server through RDP, they can have their own Brave session running but no-one can have multiple RDP sessions running Brave on more than one of them.

This happens on all servers, regardless of the username or privilege level.

Only 1 RDP session, per user, can run Brave at any one time.

All versions of the O/S (2012, 2016, 2019, 2022) are affected and all versions of Brave, even the latest.

Brave is up to date: Version 1.48.171 Chromium: 110.0.5481.177 (Official Build) (64-bit)

1 Like

Hi there @Pantec are you able to connect a second session using a different chromium based browser such as Chrome or Edge?

If they work, please let me know.

Yes, normally have to use Firefox or Edge. Those browsers work fine in multiple RDP sessions with the same user, just Brave that doesn’t.

1 Like

@Pantec could you please try creating a new profile on Brave by going to main menu > create a new profile and then trying to connect to two sessions to see if you are able to do so?

I have created a new profile and logged onto a second RDP session. Brave will not start either for the original shortcut nor the second new profile.

1 Like

@Pantec, try disabling Hardware Acceleration in settings to see if this resolves the issue. You’ll find this in brave://settings/system > Use hardware acceleration when available > toggle off > relaunch Brave.

Nope… no banana… nada… zip…

1 Like

@Pantec do you have ant extension installed on Brave that may be interfering with RDP sessions?

  1. On your computer, open Brave.
  2. At the top right, click MenuMore toolsExtensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.
Regards.

No, nothing.

It is a bug, have you tried it yourself?

We are an IT Solution Provider, we install servers and PCs all the time. Every PC we supply we install Brave and set as default, every server the same.

This issue happens on EVERY server, whatever the version of Windows Server. There are never any add-ins, plug-ins, any other fancy or weird stuff installed.

It happens on a brand new, freshly installed server with no other software installed whatsoever.

My many years in this industry supporting many different servers is telling me that it is Brave profile related. It ONLY happens “within” the same user. You can have 100 people logged onto the server via RDP, each of them running Brave no problem. The moment ANY user connects a second RDP session, the second RDP session cannot run Brave (if they are already running Brave in their first RDP session).

I thought I explained that in my original message, keep coming backwards and forwards is getting nowhere. Sorry to be abrupt but this is the problem.

1 user (ANY user) on the same RDP server with 2 RDP sessions cannot run Brave in both sessions.

This does not happen with Edge, nor Firefox, nor Chrome - it is Brave specific.

1 Like

Thanks for the information, I’ve shared this with our team and I’m waiting for further information on the matter. Once our team has answers, I will get back to you as soon as possible.

You should go to chrome://version in Chrome and Edge and see what they are doing.
The thing is you can’t open the same Chromium browser instance twice if it is sharing the same User-Data, because the User Data gets locked, so maybe Chrome and Edge are doing something to make sure it’s not hitting the locked files? that’s why looking at version is a good start to see how they are starting Chrome/Edge and what Profile are they launching and all that.

I found many issues that talk about the same case you are describing, this is the one that could be more helpful to you since it is about Chromium, it is from 2012, where the ‘issue’ was still present in 2019 as seen by the last comment: https://bugs.chromium.org/p/chromium/issues/detail?id=160676 so you know it is not my imagination.

So workarounds for it would be -user-data-dir flag like anyone would have to do to run two instances of Brave in the same user, or I guess UserDataDir GPO policy, which you can find here https://support.brave.com/hc/en-us/articles/360039248271-Group-Policy, would be better for you, and variables to make stuff ‘automatic’ and easy like:

So launching brave like brave.exe --user-data-dir=%LOCALAPPDATA%\BraveSoftware\Profiles\%CLIENTNAME% or %SessionName% should work?

someone also mentions ${session_name} in the UserDataDir policy so you might want to read some of the replies there to get more ideas how to workaround this issue.

This is why I don’t know how you said it worked in Chrome and Edge but not in Brave, they can’t magically workaround the locked files so maybe they just do it automatically or something.

Of course this comment is more about suggestions rather than quick fixes, but hope I am not too far about understanding the issue you mention, I don’t do RDP stuff, but seems like that’s the reason, Chromium user data getting locked, getting so locked you can’t modify any file or anything, because when you close the browser it will ‘bake’ the changes or you can’t open SQLite files while Browser is running and all that.