Brave on older versions of iOS

ios

#1

I use an iPad 3 which ended its iOS upgrades at version 9.3.5. I recently deleted my copy of Brave, thinking a reinstall would speed things up. I found, however, I can’t reinstall it from the App Store, the current version of Brave limited to iOS 12. I reinstalled Brave from a backup on my PC, but it appears to be a very early version.

Is there anyway to find and reinstall the last version of Brave for an older version iOS? If not, how can this be requested? Many apps will offer you the last version of their app for an older iOS when they detect you don’t have the current one. It would be nice if Brave did so as well.


#2

cc @joel @sriram on this. Since I’m not really sure about that.


#3

The official supported version is now on iOS 12 only. Unfortunately we don’t have the option to support older versions. Your Appstore might be able to provide the older version that is supported on 9.x.x. Again we do not have the control on this and its totally at Apple Appstore discretion. You could side load the app by downloading it from here but remember this is a very old version(1.6.1) and would not get any update (ever) from Brave. There’s no guarantee that the appstore would update to the last supported(1.6.6) version on 9.x.x as well. Its totally up to the appstore to detect and provide update.

I know its annoying to hear this but you will need a device that supports iOS12 in order to use the updated app.


#4

Sriram, thank you for your response. I’ll try the side load you suggested. I don’t know what version of Brave I restored from my PC, but I’m guessing it’s probably even earlier than 1.6.1, which would show some improvements over the version I now have.


#5

I joined the community just to ask this question too. I have an older iPad and would love to run Brave on it. We are not in a financial position to buy a new one. I really like the sounds of Brave but it sounds like I have no real option to use it.


#6

Unfortunately this is something that is not under our control. Like I suggested in the post above you can download the older version and install and try to get an update to 1.6.6 but the update is totally up to the Appstore to provide.


#7

Sriram, I tried to install the Brave 1.6.1 ipa, but iTunes said I needed a later version of iOS than what my iPad 3 has, which unfortunately stopped at iOS 9.x. Thanks,

John


#8

I don’t understand why this is not under your control: Brave is the only app that I know that requires iOS 12. OTOH, Whatsapp, Firefox, Gmail, Gmaps… all of them keep supporting at least iOS 11, and probably earlier (I keep receiving updates from all of them). If the reason is that the new webkit you chose requires iOS 12, then that was a very wrong choice, because the Apple users who care most about privacy are precisely those who prefer not to update iOS. I really don’t understand.


closed #9