Brave on Mac now makes a connection to Google on start


#1

The new Brave browser makes external network calls on start:

  1. updates.bravesoftware.com
  2. go-updater.brave.com
  3. client2.google.com

Even with every search engine but DuckDuckGo removed, and with DuckDuckGo set as the default, Brave tried to connect to www.google.com on a fresh browser start.

Brave was designed to stop tracking, yet now provides Google with immediate notice when the browser is first started up. Please disable all calls to Google’s servers and block Google’s tracking scripts.


#2

Hi @revers,
Thanks for reaching out.

Brave do removed codes that can phones home to Google. cc @Mattches on this one since I’m not sure which issie that cause this.

:slightly_smiling_face:


#3

I think the google connection may be related to extensions from the Chrome store.


#4

The problem with allowing Brave to automatically reach out to any Google server is that it provides Google with a way to further monitor users. I refuse to use Google’s services and applications because of their abusive practices, and the polarization of society they have caused. There should be an option to allow users to disable all connections to Google’s servers and services.


#5

You may want to search through existing Q&As as this has/is already being addressed…for example…

You may also want to look at the document the developers have created in relation to this theme:

Otherwise, maybe one of the developers may opine. I am a user and this concludes my effort to be helpful.