Brave on Linux (Debian) and sandbox issue

linux

#1

I have installed Brave on Debian for a first try today and, when i launch it in terminale, i get a error message:

[4937:4937:0217/113238.623368:FATAL:zygote_host_impl_linux.cc(126)] No usable sandbox! Update your kernel or see https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the SUID sandbox. If you want to live dangerously and need an immediate workaround, you can try using --no-sandbox.

The problem is that the pointed page is claimed outdated! :

IMPORTANT NOTE: The Linux SUID sandbox is almost but not completely removed. See https://bugs.chromium.org/p/chromium/issues/detail?id=598454 This page is mostly out-of-date.

This second message send to a page from 2016 wich talk about «Stop checking for the setuid sanbox binary on desktop Linux» in chromium. Maybe Brave developpers should do the same?


#2

The same here! My spec

  • Debian 9.4
  • Linux vouz 4.9.0-4-amd64 #1 SMP Debian 4.9.65-3+deb9u1 (2017-12-23) x86_64 GNU/Linux
$ brave
[32755:32755:0410/100335.233424:FATAL:zygote_host_impl_linux.cc(126)] No usable sandbox! Update your kernel or see https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the SUID sandbox. If you want to live dangerously and need an immediate workaround, you can try using --no-sandbox.
Aborted

#3

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.