Brave not working after update

Hello,
after last upgrade from stable channel the Brave stoppped working properly. It only shows background colors (black for header, white for all the remaining window) - no buttons or any other controls, nothing. Nothing else was updated in the system.

Please help how to solve this, thank you.

Brave version: 1.13.82
OS: Linux Mint 17.3 Rosa
(kernel: Linux 3.19.0-32-generic)

Edit: Downgraded to 1.12.114 and now everything works, except I have lost several windows and history.

Same issue as above.

Brave Version 1.13.82
Linux Mint 17.2 64bit
Cinnamon Version 2.6.13
Linux Kernel 4.4.0-148-generic

I downgraded to Version 1.10.97 Chromium: 83.0.4103.116 (Official Build) (64-bit) and it is working fine again. I downgraded further back because a prior upgrade wiped out all of my passwords.

After updating, Chrome presented the same issue with the blank screen and black header with no controls or buttons.

I turned off Hardware Acceleration as suggested in this thread ([SOLVED] After updating the new version of the Brave browser there is no image) and was able to successfully upgrade to 1.13.82. I did the same for Chrome and it also successfully upgraded.

I searched for a fix for losing all of my passwords when I upgraded from 1.10 to 1.11 but only saw one unanswered post.

1 Like

@penelope,
Did you lose your passwords after downgrading, then upgrading? Or did you lose it way back during the update to 1.10x --> 1.11x?

I lost them when I updated a month or so ago. I’m not positive that it was 1.10 to 1.11 but it was around that time. When I downgraded today, I chose 1.10 because I thought it was before my passwords were wiped. I figured I might rectify two bugs with one downgrade. Fortunately, they appeared again when I downgraded. I copied them and then when I updated to the current version, I manually added them.

I just tried to pin that down and it was either when I updated from 1.10 to 1.11 on August 2 or from 1.11 to 1.12 on August 19. I didn’t look into it at the time because I was confident they would reappear in a subsequent update.

Ive replicated your bug @Lukas within the VM. Ive no access to real (non-VM) inastall of Brave so am unabke to check there.

@penelope,
Do you happen to have more than one browsing profile?

Not that I can remember having intentionally created and I’m the only one with access to the computer. If you would like me to check, tell me where to look. I do have a couple profiles in Firefox.

I confirmed that I only had 1 profile. However, while exploring now I have accidentally created a second and don’t see the ability to delete it.

I was able to remove the accidentally created second profile using your guidance found here (Can,t delete profiles). Definitely not intuitive!