Brave not showing newly installed extension (Lastpass)

Description of the issue:
I just installed Brave and would like to keep on using it. However, Lastpass integration is one of the most important extensions. I switched to “Extensions” in Brave and found a link “Find extensions and themes in the Web Store”. I cannot install the Lastpass extension as the store says that it’s already installed in Chrome - which is true. But I want to utilize it in Brave.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Go to the burger menu and click on Settings
Then click on Extensions
Click on Manage Extensions

Actual Result (gifs and screenshots are welcome!):
No list of extensions - just a link to the Web Store

Expected result:
The Lastpass extension should offer automatic password insert when I open a Login window.
I expect to have an icon in the top bar of Brave which would offer the regular Lastpass functionality (as it does in Chrome)

It would be nice to see any of the installed Extensions when I click the Menuoption “Extensions” in Settings but I only see the “Find extensions and themes in the Web Store” There is just no Extension listed.

Reproduces how often:
every time I go to Settings -> extensions in Brave.

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 with live updates on.

Additional Information:
To create a topic here in the communicty one has to choose at least 1 tag - there is no freehand typing - ok - but the search does not even find the word extension??? So I chose “Windows” which is not really helpful as a tag.

@nicecap let me know if this article not solve your issue https://support.brave.com/hc/en-us/articles/360017909112-How-can-I-add-extensions-to-Brave-

Hi eljuno.

Unfortunately this article won’t bring me any further than to the following screen.

When I click on More Tools -> Extension this is what I get:

Howdy, @nicecap, and welcome. I use the LastPass Extension with all of my Braves on Windows and Mac, so it definitely works, so let’s try to get you working. I’m going to assume you’re using the main version of Brave (0.66.99), not the Beta, Dev, or Nightly versions, but the only difference in what I’ll write is the name of one folder in some related paths. For your reference, typing brave://version in the address bar is another way to check your version, and brave://help will show that plus check for updates.

Also, when you’re on the web store, it refers to Brave as Chrome, so it’s really reporting that your extension is already installed in Brave, which is weird unless you copied your profile folder from Chrome into your Brave profile folder, but even then, weird.

One fix would be to create a new person in the Profile Manager - that’s called from the little circular menu next to the “hamburger” menu. Try installing the extension after switching to the new person, and if it works, import your stuff to that person and use that as your main.

If you don’t mind a little troubleshooting, it would be good to know what’s going on with your installation.

Take a look in “C:\Users\YOURUSERNAME\AppData\Local\BraveSoftware\Brave-Browser\User Data\Default\Extensions” and see if there’s a folder called “hdokiejnpimakedhajhdlcegeplioahd” (the LastPass Extension folder). If you created a new person as your main, then “Default” should be “Person 1” or whichever profile folder was most recently created/modified. If the extension’s folder is there, quit Brave, delete the folder, relaunch Brave, and try to install LastPass Extension again, and let us know whether that works.

@nicecap,
Have you tried to download and install the extension from the Chrome web store yet?

Additionally – do you have any instances of Chrome running in the background at the same time as trying to install this extension in Brave?

Maybe you should try using a better passworrd manager like KeePass2

This topic was automatically closed after 30 days. New replies are no longer allowed.