Brave not showing any Ad (not even with debug)

My Brave Browser never showed me any ad since I started using it. I tried debugging and everything.
What I am using
OS: Windows 10 Pro
Brave Beta Version: 0.67.112 Chromium: 76.0.3809.62 (Official Build) beta (64-Bit)
Brave Beta ads not showing up : Chrome_debug.log doesn’t include “Notification not made”.
Windows allows notifications.
Ads are turned on and limit is 5.
Country: Germany

Another thing I am curious about:
When I go to then sometimes there is something in “campaigns”: and other times not.
I thought that there should always be something in it.
Thanks in advance, Zerobyte.

@Zerobyte Thanks for the detailed info. Could you please hit the URL and check whether the catalog is downloaded for your region or not? If catalog gets downloaded then you should be able to see ads.

Please paste the catalog content here in this thread.


Thank you for your fast answer!
In the morning (about 6 am CEST) the catalog is downloaded and now (about 11 am CEST) not.

@Zerobyte Could you please check does catalog has any ads categories? If possible can you paste the catalog content here, so that i can check catalog has ads categories or not.

For example:

If ads categories available, catalog should look like this (as shown in below image). Here you can see payload, segmanet, ads title info for ads category. This catalog is for country Australia, if you visit you should be able to see ads. Basically ads will be triggered based on the Ads categories available in the Catalog file. For example, If catalog contains 4 categories for your region ( Personal Finance , Technology & Computing , Business and Education ). If you browse any website, if it falls under any of these categories then ads will be triggered.

If it’s clear, you can verify from your end or elase revert back if you see any issues.


In the morning the catalog is filled and brave shows ads (that works now). But after 3 hours and a pc restart this comes again:


Thanks, Zerobyte.

@Zerobyte Thanks for the sharing catalog content. Catalog is empty, that’s why you are not seeing ads. Did you change any OS settings after restarting the machine?

Can you provide below info:

  1. Run and see IP points to which region
  2. What is the language set in OS.



  1. Region: Germany, Bavaria
  2. Language in OS: German (Germany)
    Thanks, Zerobyte.

Have the same problem.

Catalog is also empty and

  1. Region: Germany, Berlin
  2. Language in OS: German (Germany)
    hope for solution.

@Zerobyte Did you change any system settings after restarting the machine?


No, I changed nothing.

1 Like

@Zerobyte @creaders I am checking with ads team will get back to you once I get the answer.

Thanks for your patience!

Thank you very much for your help so far!

@Zerobyte Catalog is full for Germany, can you please try now?


You’re right, i got some ads now. But is it normal that on one day 12 hours browsing I get just 4 ads? On some days after 3 hours (2 ads) the catalog was emtpy. And I never got more than 1 ad every two hours.

no not working. catalog is still empty…

it worked for few hours and now it’s stopping again.
Catalog empty. no change on system. Region: Germany, Berlin Language in OS: German (Germany)…

any infos?

@gsarvadnya Is there anybody who solve this issue???

sometimes catalog is filled ok, sometimes empty!?!
Is this an issue you would like to solve?

This topic was automatically closed after 30 days. New replies are no longer allowed.