Brave Not Responding when Printing or Loading Print Preview — Version v1.50.114


The Issue: Whenever I am trying to print a webpage or PDF, Brave is freezing (not responding) or in rare cases, crashing.

When opening the “viewer” in Brave’s browser for a PDF and hitting the Print option, the “Loading Preview…” page will take anywhere from 15 to 20 seconds alone just to load, it will freeze with the “Not Responding” message for 10 seconds before it will go back to normal and let me print — or in one rare instance, the Loading Preview screen turned white and then the browser completely crashed.

Steps to Reproduce:
1. Open any PDF on Brave v1.50.114 (Example PDF that I’ve copied from This Forum Post about a similar situation)
2. Click print.
3. “Loading Preview…” takes 15 to 20 seconds before the “Brave - Not Responding” occurs.
4. Wait for it to stop freezing/respond, or see if it crashes.



Reproduces how often: Every single time I open a webpage or PDF to print.

Operating System and Brave Version:
Brave Version: v1.50.114
Operating System: Microsoft Windows 10 Pro

Additional Information:
In attempts to fix this on my own, I have tried the following:

• Uninstalling and reinstalling Brave.
• Checked Windows Update and updated to the latest version of Windows.
• Adjusting the Hardware Acceleration Settings within Brave, as well as Cleared Browsing History/Cache.
• Looked through many forum posts about this issue, or similar issues - but none that I have found have any confirmed resolve or fix, or are outdated.
• Tried Brave on a different computer/restarting both.
• Tried Removing or Uninstalling Extensions.
• Tried other browsers and they do not produce this issue:
(Chrome Version 112.0.5615.50 + Opera GX Version 97.0.4719.63)

After all of this: Sadly Brave’s issue still persists.

Conclusion: Does anyone have any idea or solution to fix this?
Am I doing something wrong, or is this due to Brave’s Update and needs to be addressed by the developers?

Any idea would help. Thanks!

— Darling.


Same problem here. v1.51.110. Couldn’t find an option to change the default ‘save as pdf’ to make other tests.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.