Brave not responding on Catalina

@karmajampa,
In macOS, go to Settings --> Privacy and Security and see if you’re able to give permissions to launch Brave from here.

Unlocked security and selected to open anyway, Brave immediately crashed, selected reopen, crashed again, selected send report to Apple.
Presume you will get a report also ?

@karmajampa,
Thank you for testing that – although I’m still not sure what’s happening here. There are other issues surrounding Catalina that the team is working on presently. I’ll be back here when I have more info or additional tests to try.

1 Like

Thanks, the Youtube ads are too much !

@karmajampa, hi. I hesitate to ask this, but are you trying to run Brave directly from the opened disc image? If so, that very well might be part of the problem. Usually the opened disc image will show Brave and a shortcut to your Applications folder. Drag Brave onto the shortcut to copy Brave into your Applications folder, then double click the shortcut, find Brave, and run it from there.

You can always get to the Applications folder by clicking on your Desktop or on the Finder icon in the Dock, then either doing shift-cmd-A or using the Go menu and selecting the Applications folder.

Here are some images to illustrate (albeit in Mojave - I have some 32-bit apps holding me back):
Opened disc image:
image

Copy Brave:
Copy%20Brave

Open Applications folder, open Brave:
Open%20Apps%20Run%20Brave

Good idea but no luck, however, Brave was still in the doc but with a comment that it could not be found, removed it from the doc and relaunched from applications, it appears to launch then immediately close, going into the doc there is again a link to Brave so something definitely happened !
Did the same with the Brave beta version, moved it into applications and launched, this time it shows in doc as still open but unresponsive and a link to force quit.

@karmajampa,
Can you go to ~Library/"Application Support"/BraveSoftware on your macOS and confirm that there is, in fact, a Brave-Browser folder located here? Further – if there is – can you open the directory and confirm that there is “stuff” in this directory? Namely a Default and/or [the name of your user profile] in there?

Empty, i.e. no folder for Brave or Brave beta.
Did you note that I added to this post that the beta appeared to open but be unresponsive, in the doc it gave me the option to force quit.

K.

Sorry, wrong library !
Yes there is a brave software folder, brave browser and a default folder with stuff in it.
In the Brave folder theree is a guest profile and a profile 1 folder.

I’ve done nothing additional to try and get Brave up and running again, beyond reinstalling Brave and saving my bookmarks etc… like I had mentioned a few days ago.

So this morning, Brave opened, with bookmarks and is working just fine.
No Crashes anymore.
Not sure if you guys solved the issue on your end or what. Very odd but also very happy once again.

1 Like

@Adventureland,
Thank you for reporting. We did release a hotfix update to v0.69.135 which fixes Sync crashes/issues in some cases. This may be why you’re no longer encountering the crashes.

1 Like

Nice job, thank you.

Unfortunately it did not work for me, left link in Doc but failed to open completely.
Brave was initially installed on Mojave and present after Catalina, then after problems I cleaned with appCleaner. Perhaps this why this recent update will not work. Brave and Brave beta remain in doc with prompt to force quit as they are not responding.
Reports sent to Brave and Apple I believe.
n.b. I did find a default folder in the correct Library under Brave software.

@karmajampa,
I know that you said earlier that you’ve already un/reinstalled, but I think it may be worth another go. Lets remove all traces of Brave and try a clean install again:

  1. If you want to keep your user data, make a safe copy of the Default folder you found above (as well as any other additional browsing profiles you’d like to keep) because we’ll be deleting this entire directory. Once you have a safe copy, move to the next step.
  2. Make sure no Brave processes are running. Then, remove the icon from the dock.
  3. Visit ~/Library/Applications and trash Brave Browser.
  4. Visit ~/Library/Application Support/ and delete the BraveSoftware here.
  5. Repeat the process for Beta if you want, but it’s not necessary at this time.
    • There should now be basically no traces of Brave (Stable) on your machine.
  6. Go to our official website and download stable again.
  7. After installing – don’t replace the Default folder just yet. See if the browser launches and runs on a clean profile first.

If it does, feel free to replace the profile folder with your safe copy. If it doesn’t…tbh I have no idea at this point. The team expected there to be some issues with Catalina but we are still in the process of sorting everything out.

Let me know what happens

Thanks for your support.
Still does not want to open, leaves link in Doc and software file in Library, requested access to keychain in Brave folder
I will wait and try again at a later date and continue to observe this list.

The Catalina installer will warn of you apps that will not be compatible before the upgrade process begins!

Some progress made, however, still issues.
I downloaded a new disc image, it launched but had no windows, forced quit as I could not close it, relaunched and this time had a window that appeared correct, entered the Youtube link in the address field and Brave crashed and will no longer load
I pasted the default folder from a previous version but still will not stay open.

This may seem tiresome, but could you confirm that you copied Brave from the new disc image into your Applications folder, and that you were running Brave from the Applications folder? This is important because what’s on the disc image is the actual Brave application, not an installer, and it just doesn’t work right if run from the image (at least in my experience).

The behavior you describe I observe when I try to run Brave from the disc image, which is not the way to do it. When I subsequently open Brave from the Applications folder, it’s fine.

The presence of the “links” you describe means different things depending on where in the Dock the icons are appearing. For example, in the right portion of my Dock there is a “Recent Applications” stack that will show the last 5 or 10 applications run with the most recent being visible in the Dock.
image
Trying to use the one from the time I ran Brave from the disc image will try to open Brave from the disc image. If the image is ejected in the mean time, then Finder will not be able to locate Brave and that could lead to the message you mentioned about Finder not locating Brave. [Edit: Trying this scenario with a Google Chrome download to try to replicate your subsequent post, my Finder unexpectedly re-mounted the disc image and opened the application. I did not expect/want that and will have to chase down the setting that allows this and turn it OFF.]

It’s often helpful to include screenshots and short videos in GIF formats. For screenshots, Shift-Cmd-3 will do the whole screen and Shift-Cmd-4 will change your pointer to a crosshairs you can use to draw a rectangle of your screen you want captured (a thumbnail of the capture then appears in the lower right of your screen and if you right-click it, you can tell Finder where to store it; by default it goes to Desktop if you don’t click on it). For the videos, LICEcap is a powerful tool. For more on these, check out

I launched Google Chrome and had a similar crashing that I have had with Brave, i.e. after launching I entered an address into the search field and upon pressing to search Chrome crashed.
I relaunched and in Preferences went to disable sync, upon doing so Chrome again crashed.
This is version 77.0.3865.120 official build 64bit

This topic was automatically closed after 30 days. New replies are no longer allowed.