Brave not respecting individual shield setting causing high CPU usage on certain website


Intel Mac
MacOS 13.0 (problem was present in lower version too).

Brave browser Version 1.45.116 Chromium: 107.0.5304.91 (Official Build) (x86_64)

Steps to reproduce :

  1. Goto global shield settings in brave, change tracker protection to “Aggressive”.
  2. Open the problematic website.
  3. Confirm the usage in the task manager. CPU remains in high 80s continously for as long as the website is open.
  4. Changing the global shield to “Standard” and then refreshing the page solves this issue.
  5. Weirdly, switching off shields for this specific website (obvious solution) didn’t work and only the global change impacts it.

This is the bug. Brave is not respecting the local setting of this website for some reason and then some conflict in this website is causing this high cpu issue.

Please do look into this as to why the local website settings are not being respected.

Issue with : (this needs login)
(might be more but this one for sure. )

As soon as the website is logged in, there is high CPU usage and fans run at full speed.

Give 24hrs and retest, was removed

1 Like

Works perfectly!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.