Brave not counting background ads

Briefly describe your issue:

What Operating System and Brave version are you using (Menu --> About Brave)? Windows 10, Version 1.41.96 Chromium: 103.0.5060.114 (Official Build) (64-bit)

Is your browser wallet currently verified? (yes/no) yes

What date did you verify your wallet? don’t remember

Have you been able to successfully receive payments in the past? YES

Are you using a VPN? (yes/no) NO

Are you in a supported region (see here for list of supported regions)? YES

Does your device pass the SafteyNet check (Android only)? YES.

ISSUE -: Background ads not getting counted on desktop, on the mobile app there’s no problem. And on desktop too notification ads are fine, it’s just the bg ads that are not increasing the count.


@sampson kindly help please.

Would you kindly submit your issue here and we can investigate further?


1 Like

Same happening to me on brave beta and nightly version on both pc and mobile. After i updated to latest version per day only 1 ad i get . Brave stable version is also acting weird . i doesn’t count background ads if i continously open new tabs. Please help me eith solution , Thank You.


Yes same issue with me :slightly_frowning_face:

It’s being said that versions 1.41.xx have different NTP (background ads) capping logic. It may be the cause.

For now, you can downgrade to 1.40.xx or lower in order to maintain the NTP 24 ads/day 4 ads/hour limits.

Yes. I also noticed it has changed. Try and relaunch the browser to see if you can earn NTP on second new tab refresh. It’s still working for me this way.

How to downgrade version? can you tell me steps please? Thanks.

Hmm… it may be a bit tricky due to the Auto Update process.

But in case you have it disabled… simply uninstall current version (DON’T DELETE BROWSER DATA!) and install any Standalone version from here.

This thread has a good discussion about these new limits and auto update.

Please remember it’s all on your own risk of course.

1 Like

Thanks for the information.

You welcome.

Please give us a feedback if this workaround is working for you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.