Brave No Longer Saving UN & Passwords? 012119

performance
macos

#1

Version 0.58.21 Chromium: 71.0.3578.98 (Official Build) (64-bit), MacOS 10.12.6

Brave seems no longer to be asking to save passwords and subsequently, not autofilling user name and pw at sites like Twitter. (For example.) Went through Settings, turning things on and off. Rebooted variously. Switched the few extensions I use on and off. No results other than those posted here. Anyone else having this problem?


#2

Which settings did you toggle?

Are any of the extensions password managers?


#3

Thanks for checking into this. I appreciate any help.

Settings > Passwords

Toggled both Offer To Save and Auto Sign In individually and together.

Settings > Privacy

Cleared all options under Advanced for All Time. Twice. Then unticked Passwords & Other Sign In Data; Autofill Form Data; Hosted App Data; Media Licenses

Cookies are set to block Third Party and keep local data only until quit.

Extensions are the following:

AdNauseam 3.7.802

CookieBro 2.7.2

URL Shortener 1.0.2

Click&Clean 9.5.4.1


#4

Just to be sure this switch is on right? If this is off then it wont save any passwords any more


#5

Yes, it’s on. Part of what’s so puzzling.

Btw, if this is helpful, I also attempted to reinstall the browser. I have a Mac app, App Delete, that is good at rounding up associated files during an uninstall. (Rather than merely dragging the application to the trash.) I used that, emptied the trash, reinstalled Brave. However, the preferences from the previous install were still there. Clearly not everything got removed, although as said, App Delete is generally quite good at getting everything. I also have Chrome installed. Think anything might be related?


#6

@Ructions,
I would recommend removing the “clear on quite” rule for cookies - may be causing issues somewhere in here. Also, I’d recommend disabling all of your extensions and then trying. Additionally, what happens if you manually add a new password to Brave? Is it remembered?


#7

Thanks for weighing in, @Mattches. Sure hope this isn’t becoming tedious. Did what you suggested and tried logging into Twitter and one other site requiring UN/PW. Nothing saved nor offered to on the second site and Twitter only remembers UN. (Previously, Brave autofilled both un and pw on both sites.)

As to manually adding a password, I searched around and if there’s an option to do that in Brave’s settings, I seem to have missed it. Can you point me to the steps. Thanks


#8

Try these:


#9

Thank you. These are things I’m familiar with, but they indicate I’m not getting the pop up window to edit, see or save the un and pws. All extensions are off. Most Brave settings are default. I switched off “Block Pop Ups and Redirects”, tried again with no luck then switched it back on. (Recommended) I’ve been through the settings inch by inch about ten times now. No idea why that window isn’t being offered. Again, I have Chrome on here as well. Any chance there is some cross reading between the two? Seems unlikely and I certainly hope not.


#10

@Ructions,

:point_up: Definitely not. But this is pretty strange.
I’m wondering if you’d be willing to take a short screen recording of an attempt to log into and save your password for a website.

To ensure that you aren’t giving away any personal information, you can create a temporarily account here on Community for demonstration purposes (once the issue is resolved, I can delete the account on my end).

Not that I don’t believe you or think you haven’t tried a million different things - but seeing the behavior in action may help diagnose the problem. If you’re willing, take a short recording of the following:

  1. Visit a site and attempt to login to it as normal
  2. If prompted (I know you said it doesn’t appear but just in case) elect to save your UN/password
  3. Log out of the website, close/relaunch Brave, and return to the site you logged into in step 1
  4. Click in the text input field to reveal (assuming the issue is still occurring) your UN/password not offered as an autofill option.

Additionally, a screenshot of your password settings page would be helpful as well. You don’t have to include any of your data in the shot, just the top part like so:

Note: You can use LICEcap to record screen activity. It’s free, open source, and very easy to use (also extremely lightweight).


#11

Okay, took screencaps of Passwords, Extensions and a few Settings.

Took a recording of Brave Community login (no offers). Logged out; quit Brave; logged in. No change in existing situation.

Nice tip with LICEcap. Very useful.

Puzzler, isn’t it?


#12

PS: Happy to email you anything that didn’t come through or might otherwise be required.


#13

@Ructions,
Thanks so much for the info/screenshots. Glad you liked LICEcap as well!
Still not sure what’s really going on here.
Type brave://flags into the address bar and search for a flag called #fill-on-account-select

Can you tell me what this option is set to? If it’s not enabled, set it to be, relaunch the browser and try saving your PW again.


#14

@Mattches You’re a trooper for hanging in here. I was all set to tip my hat with that flags suggestion, however after locating it and changing Default to Enabled, the current situation persisted unchanged. Might a clean reinstall might solve the problem? Can you suggest a way to thoroughly remove Brave? As noted, I tried before, but somehow the new install found some previous data and reset to the earlier version that had been giving me this same problem.


#15

A clean install may help. Also I’m out of ideas :stuck_out_tongue:
Assuming you have any browsing data/bookmarks backed up somewhere (or don’t care about them enough to do so), you can clear all data by (macOS):

  1. Send Brave application file to Trash
  2. Navigate to /users/[your user name]/Library/Application Support/
  3. Locate the BraveSoftware folder in this directory and delete it (this will get rid of any Brave browsing/profile data)

You should now have a “clean slate” with respect to Brave on your machine. Now just download Brave as normal and see if the issue is resolved.

Additionally, if this proves unsuccessful, you can also try downloading the Beta or Developer build of Brave as well. They install in parallel without conflict, so you don’t have to delete or uninstall any of the other builds in order to install another one (nor will one channels data overwrite another).


#16

@Mattches Thanks for all that. And the suggestion for the Beta and Dev versions. (Should have thought of that myself.) I won’t bother you again with all this, but please know I really appreciate your time and attention. It reflects well on Brave that they have you.


Brave doesnt save passwords
#17

@Ructions, you’re too kind! I appreciate that!
It’s no problem at all - that’s what I’m here for! I also enjoy solving problems. You’re welcome to continue bumping this thread as long as you want - I’m sure there’s a solution to this!

Did the clean install not resolve the issue?


#18

Interestingly, installing the Beta build did not work. In looking to do a thorough uninstall of both the Beta and Brave, I found Apple is hiding the User Library folder in current versions of MacOS. (If any Mac users are seeing this and want to make it visible, type the following into Terminal and hit Return. chflags nohidden ~/Library) Once I was able to access that folder (thanks for pointing me there, btw) I cleaned out all Brave/Beta related files, reinstalled and now have Brave’s Password Manager functionality. Thanks again, @Mattches


#19

Phew, thought that one was going to get away from me. Glad we could get it resolved :slight_smile:


closed #20