Brave News Not Loading

Brave News is not loading on Nightly after update. Sources empty. I tried toggling option off/on, clearing history/cache/cookies for all times, exiting and reopening, and still will not load. I do not use extensions.

Brave 1.51.29 Chromium: 111.0.5563.64 (Official Build) nightly (64-bit)
Revision c710e93d5b63b7095afe8c2c17df34408078439d-refs/branch-heads/5563@{#995}
OS Windows 10 Version 22H2 (Build 19045.2604)

Thanks @Chocoholic, it’s working as expected for me. Looking into it.

@steeven I am facing the same issue. Just letting you know so if you guys need info, you’ll have a wider set!
Thanks @Chocoholic for pointing out!

A fix is on the way!


FYI - No change with newest update.

Well, that PR says Brave news are broken so I guess you will have to wait for it to get merged and the build is out.

1 Like

@emi Thanks for link! I never would have found that! I also looked at the issue report and I never would have thought that was related to this topic. So thanks. It does have merged now.

When I go look in master, it has the package as 1.51.34. Does that mean the next version release is 1.54.34 or does that mean any version release with a higher number will have that fix?

It is working as 1.54.35.
What you do is to look at the commits, because commits = what was merged and will be/is available in Nightly, then you look if there is a build done for it, if not you wait, and if it is available, then you have to wait to see it in the downloads but It takes like 4 hours from the moment it gets posted, to when there is a Windows exe
download, so sometimes it’s just waiting some hours and done.

BTW look what was merged too! enable chrome://flags/#brave-commands

and go to brave://commands/ (until they finish the settings page for it.)

:grin: any shortcut can be edited, even ones that not even Opera and others allow, like Caret Browsing, which is annoying to enable and useless for pretty much anyone.

PS. and yeah, I don’t even remember why I clicked in that PR, maybe for its strange name, but then I saw it had to do with News, good it didn’t take long for them to merge it. I don’t use News though, but many do.

@Emi Thanks again! You are awesome and I appreciate you sharing your knowledge. I understand a lot more than I did before about how things work in Brave GitHub! :slight_smile:

I did enable brave://flags/#brave-commands in Nightly. I went to brave://commands and clicked on one of the shortcuts. The message snipped below displayed and really made me hesitate! Clicked it anyway. Figured the worse case scenario was I had to reinstall. Glad Brave (or my system) didn’t crash. :sweat_smile:


I think the ability to configure shortcuts is going to please a lot of people. That caret browsing toggle is annoying! And I bet gamers gonna be happy campers too. lol

Thanks again. Take care. :slight_smile:

Oh, the customization of keyboard shortcuts and the fix for the news, should be .35+ (probably you got it by now)

You would even go and remove the left and right arrow (by clicking the - button next to the shortcut), because for some reason they are set to navigate back and forward.

That commands page you are talking about was the one before, that would only show all the commands available but now they added the editing part, and next step will be editing in Settings for everyone to use.

BTW you can always got to GitHub and force any nightly, because Brave only pushes 1 Nightly daily through the updater, but couple more builds are made through the day, so what I do is I check commits, if it is worth it I update, if not, I won’t (I disabled automatic updates).


Fixed in Nightly version 1.51.38. :slight_smile: