Brave News feed returns to the top/start of the news feed

Description of the issue:
How can this issue be reproduced?

  1. Scroll down into the Brave News feed
  2. Click into a news article
  3. After reading, click the Back button to return to the Brave News feed
  4. Brave News feed returns to the top/start of the news feed
  5. Reader must re-scroll past news articles to return to previous spot in the news feed

Expected result:
Click the Back button and return to the previous spot in the news feed to continue scrolling down for more news articles.

Brave Version( check About Brave):
Version 1.40.105 Chromium: 103.0.5060.53 (Official Build) (64-bit)

Additional Information:
After reading a news article, the Brave News feed returns to the very top of the news feed which causes the reader to re-scroll past previously viewed articles to get to unviewed articles. This began with the latest Brave update.

I have my Brave News feed customized to be essentially a clearinghouse for the news sources I want to see and use it extensively for lots of reading. It’s just an aggravation factor to have to scroll past all the previously read news articles to get back to the new ones.

…excellent browser.


Check these:

For Windows 11:

  1. Open Windows Settings
  2. Search for Keyboard and open “keyboard accessibility settings” @ bottom
  3. Apply settings as in image below

For Windows 10 go here

Sorry, this does not involve the OS or the Windows key. This is on the home page of the Brave browser, “Scroll for Brave News” feature. My Windows key is working nominally.

1 Like

Try disabling extensions.

New install (no extensions) on a different laptop and the news feeds acts as described above.

Same here.
But this also happens with firefox → new tab.

I don’t know why this happens, to avoid it i’m right-clicking the article
and open it in a new tab.

Not perfect, but i can live with it.

1 Like

Yes, this is the trick I use in most websites when I want to come back to that page without missing the point where I was


A new feature about the news was added in the last update: It is on by default and may be causing the problem.

  1. Open brave://flags/ and search for NEWS
  2. Disable Brave News prompts on New Tab Page (as in image).

@CerealLover, this only stops the “peeking” of the first article in the feed.

@Murphmeister and @rodrige, I also do this but with CTRL/left-click to open in new tabs and not lose my place in the loooong news feed of the original tab. I open several and read, read, read.

@Mattches you have any ideas about this in regards to if it can be passed on to anyone for the future?

And yeah, @CerealLover they are talking about when you click on an article, it brings you to a new page. Then if you hit Back on your browser to return to where you clicked, it’ll be on the top of the Brave News portion. So then you have to scroll down to where you were. They are essentially suggesting Brave remember where in Brave News they were prior to clicking the article, so they can just continue scrolling down and seeing the rest of the news.

I’ve passed this information on to the team. I definitely think it is something that can be adjusted in future releases. For now, a workaround you can use is to Ctrl + click or Cmd + click the link in the News feed, as it will open in a new tab and you will not lose your spot on the news feed.


Thank you, @Mattches

1 Like

on a 3 button-mouse clicking the scroll-wheel will also work

1 Like

I tried all the suggested workarounds, but nothing works. When I press the CTRL key and click nothing happens. To me, it was working before one of the upgrades a few weeks ago.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.