Brave make my computer freeze

Hello,

I have a huge problem since yesterday and don’t know why. I’ve always had several tabs opened with no problems since several months I use Brave. And yesterday, for no reasons when i opened this page :

everything went crazy. My mouse stopped responding, i couldn’t click for few minutes, sometime few seconds, explorer.exe stopped working weirdly. I almost felt like i got hacked, or my mouse got a problem. Alt tab was working and my game was working as well.

So I checked my mouse driver, change my mouse and it’s not coming from it.
I changed to google chrome and then the probem stopped. So it’s definitely coming from Brave. And I have no idea why.

I cleaned the cache, the history and the cookies of Brave. No change. I uninstall and reinstall. No change. There is definitely a problem with this page on Brave.

Do you need reports or my configuration ?
I’m on windows 10 and even thought it was due to an update that was downloading. But after installing it doesn’t change anything as well.

I am pretty sure it has something to do with the computer because I have had brave for almost a year now…

but no problems…

Hello @Killshout, thank you for letting us know about this. Have you updated to the most recent version? Are you using extensions? Might be one or some of of them are interfering? Does the same happen in a private window?

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Let us know if that fixes the issue. Regards.

I have disabled Hardware acceleration because I read a thread already on the subject. Sorry i should have mention already. I also tried to pass the hardware to D3D9 as someone suggested. But nothing changed.

I normally have the new version of Brave because I downloaded it to reinstall.

The only thing was that I was playing a game at the same time. Maybe it is the combination of those 2.
Anyway I don’t know I can’t reproduce the problem today.

Hello again @Killshout, please try disabling Vulkan you will find this going to brave://flags > Search 'Vulkan' > Disable Vulkan > Retest Hope that can help you.

Regards.

Sorry the problem hasn’t occured again so I can’t tell you if the fix work or not :confused:
I thought my graphic card was up to date and it wasn’t so maybe that was the issue…