Brave launches but nothing happens

Whenever I attempt to open Brave on my Dell XPS 13 9360 running Ubuntu Mate, the browser opens but does nothing. DuckDuckGo homepage is not loaded, I can’t access settings, history, bookmarks, anything. Attempting to launch in terminal produces the following:

[37004:37004:0721/] Ads service is not initialized!
[37004:37021:0721/] After loading Root Certs, loaded==false: NSS error code: -8018
[37004:37004:0721/] Device registration failed with fatal error

How can this issue be reproduced?

  1. Open Brave
  2. I’m eventually told the page is taking a while to respond and asked if I want to kill it.

Expected result: It should lead to

Brave Version( checked using Synaptic Package Manager): 1.41.100

Additional Information: Have attempted launching without the GPU from the terminal as well as launching an incognito window and within firejail, as well as uninstalling, reinstalling, upgrading, and deleting the Brave Software folder in .config. I have had no success getting Brave to work properly on this machine (works fine on my Thinkpad running Ubuntu)

How did you install Brave? Seems like your package manager is aware of it, does that imply it’s an Ubuntu-provided package?

What version of Ubuntu is that?

I installed Brave via Ubuntu MATE’s Software Boutique, which automatically adds the repository as recommended on the Brave website.
I’m running 22.04 LTS of both Ubuntu (which does not have the error) and Ubuntu MATE (which does)

What do you get from the following?

which brave-browser
ldd $(which brave-browser) (assuming the first which points you at the actual binary)

which brave-browser
ldd $(which brave-browser)


	not a dynamic executable

I’m not sure why the space is there


What about
file $(which brave-browser)

And then if it’s a symbolic link, repeat with file against the link target, and so on.

Essentially we’re trying to find out more about the actual binary app, but its location is probably being obscured by multiple levels of symlinks and wrapper scripts.

/usr/bin/brave-browser: symbolic link to /etc/alternatives/brave-browser

That in turn leads to


a Link to shell script (application/x-shellscript), leading to


which, as far as I can tell, is as far as the rabbit hole goes. Attempting to launch Brave directly from that point yields the same lack of functionality described in my initial post.

The binary is probably at /opt/ then.

In which case, what does ldd /opt/ yield?

Are all the available updates applied to the Mate system?

Did it ever work on this system?

Do you have other browsers on the system? I’m especially curious whether any other Chromium-based browsers (mainly Chromium or Chrome) have the same issue. (0x00007fffbb3a3000)
	/usr/local/lib/AppProtection/ (0x00007f00af400000) => /lib/x86_64-linux-gnu/ (0x00007f00af6b0000) => /lib/x86_64-linux-gnu/ (0x00007f00af6ab000) => /lib/x86_64-linux-gnu/ (0x00007f00af64b000) => /lib/x86_64-linux-gnu/ (0x00007f00af2c6000) => /lib/x86_64-linux-gnu/ (0x00007f00af199000) => /lib/x86_64-linux-gnu/ (0x00007f00af167000) => /lib/x86_64-linux-gnu/ (0x00007f00af13d000) => /lib/x86_64-linux-gnu/ (0x00007f00af0fd000) => /lib/x86_64-linux-gnu/ (0x00007f00af0d3000) => /lib/x86_64-linux-gnu/ (0x00007f00af09b000) => /lib/x86_64-linux-gnu/ (0x00007f00aeffd000) => /lib/x86_64-linux-gnu/ (0x00007f00aee25000) => /lib/x86_64-linux-gnu/ (0x00007f00af631000) => /lib/x86_64-linux-gnu/ (0x00007f00aedd7000) => /lib/x86_64-linux-gnu/ (0x00007f00aeda6000) => /lib/x86_64-linux-gnu/ (0x00007f00aed7c000) => /lib/x86_64-linux-gnu/ (0x00007f00aed35000) => /lib/x86_64-linux-gnu/ (0x00007f00aec4e000) => /lib/x86_64-linux-gnu/ (0x00007f00aeb0e000) => /lib/x86_64-linux-gnu/ (0x00007f00aeb09000) => /lib/x86_64-linux-gnu/ (0x00007f00aeb04000) => /lib/x86_64-linux-gnu/ (0x00007f00aeaef000) => /lib/x86_64-linux-gnu/ (0x00007f00aeae5000) => /lib/x86_64-linux-gnu/ (0x00007f00aead8000) => /lib/x86_64-linux-gnu/ (0x00007f00aeac7000) => /lib/x86_64-linux-gnu/ (0x00007f00aea60000) => /lib/x86_64-linux-gnu/ (0x00007f00ae938000) => /lib/x86_64-linux-gnu/ (0x00007f00ae835000) => /lib/x86_64-linux-gnu/ (0x00007f00ae7f9000) => /lib/x86_64-linux-gnu/ (0x00007f00ae7d9000) => /lib/x86_64-linux-gnu/ (0x00007f00ae5b1000)
	/lib64/ (0x00007f00bc353000) => /lib/x86_64-linux-gnu/ (0x00007f00ae59d000) => /lib/x86_64-linux-gnu/ (0x00007f00ae371000) => /lib/x86_64-linux-gnu/ (0x00007f00ae364000) => /lib/x86_64-linux-gnu/ (0x00007f00ae2ec000) => /lib/x86_64-linux-gnu/ (0x00007f00ae2e5000) => /lib/x86_64-linux-gnu/ (0x00007f00ae2e0000) => /lib/x86_64-linux-gnu/ (0x00007f00ae28c000) => /lib/x86_64-linux-gnu/ (0x00007f00ae27e000) => /lib/x86_64-linux-gnu/ (0x00007f00ae268000) => /lib/x86_64-linux-gnu/ (0x00007f00ae07d000) => /lib/x86_64-linux-gnu/ (0x00007f00ae061000) => /lib/x86_64-linux-gnu/ (0x00007f00ae05a000) => /lib/x86_64-linux-gnu/ (0x00007f00ae016000) => /lib/x86_64-linux-gnu/ (0x00007f00adfea000) => /lib/x86_64-linux-gnu/ (0x00007f00adf21000) => /lib/x86_64-linux-gnu/ (0x00007f00adf1b000) => /lib/x86_64-linux-gnu/ (0x00007f00adf13000) => /lib/x86_64-linux-gnu/ (0x00007f00adf06000) => /lib/x86_64-linux-gnu/ (0x00007f00adef0000) => /lib/x86_64-linux-gnu/ (0x00007f00aded2000) => /lib/x86_64-linux-gnu/ (0x00007f00adec7000) => /lib/x86_64-linux-gnu/ (0x00007f00addf8000) => /lib/x86_64-linux-gnu/ (0x00007f00add4d000) => /lib/x86_64-linux-gnu/ (0x00007f00add03000) => /lib/x86_64-linux-gnu/ (0x00007f00adc3b000) => /lib/x86_64-linux-gnu/ (0x00007f00adbfe000) => /lib/x86_64-linux-gnu/ (0x00007f00adbf9000) => /lib/x86_64-linux-gnu/ (0x00007f00adbea000) => /lib/x86_64-linux-gnu/ (0x00007f00adb1f000) => /lib/x86_64-linux-gnu/ (0x00007f00adaf0000) => /lib/x86_64-linux-gnu/ (0x00007f00adae8000) => /lib/x86_64-linux-gnu/ (0x00007f00adada000) => /lib/x86_64-linux-gnu/ (0x00007f00ad99f000) => /lib/x86_64-linux-gnu/ (0x00007f00ad97e000) => /lib/x86_64-linux-gnu/ (0x00007f00ad7d4000) => /lib/x86_64-linux-gnu/ (0x00007f00ad7bc000) => /lib/x86_64-linux-gnu/ (0x00007f00ad774000) => /lib/x86_64-linux-gnu/ (0x00007f00ad72c000) => /lib/x86_64-linux-gnu/ (0x00007f00ad6aa000) => /lib/x86_64-linux-gnu/ (0x00007f00ad673000) => /lib/x86_64-linux-gnu/ (0x00007f00ad5dc000) => /lib/x86_64-linux-gnu/ (0x00007f00ad5af000) => /lib/x86_64-linux-gnu/ (0x00007f00ad4e0000) => /lib/x86_64-linux-gnu/ (0x00007f00ad4c0000) => /lib/x86_64-linux-gnu/ (0x00007f00ad4b5000) => /lib/x86_64-linux-gnu/ (0x00007f00ad377000) => /lib/x86_64-linux-gnu/ (0x00007f00ad35f000) => /lib/x86_64-linux-gnu/ (0x00007f00ad354000) => /lib/x86_64-linux-gnu/ (0x00007f00ad32d000) => /lib/x86_64-linux-gnu/ (0x00007f00ad324000) => /lib/x86_64-linux-gnu/ (0x00007f00ad316000) => /lib/x86_64-linux-gnu/ (0x00007f00ad30f000) => /lib/x86_64-linux-gnu/ (0x00007f00ad2f9000) => /lib/x86_64-linux-gnu/ (0x00007f00ad2d3000) => /lib/x86_64-linux-gnu/ (0x00007f00ad2c6000) => /lib/x86_64-linux-gnu/ (0x00007f00ad2a3000)

I’ve been updating regularly, hoping one would be pushed that solved the problem. No joy there. It was, and remains, my default browser on the system. Currently using Firefox for internet browsing right now (which I know doesn’t help you due to not being Chromium based).
They’ve never been installed until now, but I checked Chrome and Chromium to assist trouble shooting. Chrome does not work. It returns the same

[12280:12351:0723/] After loading Root Certs, loaded==false: NSS error code: -8018

error that Brave did. Chromium does work, however, it’s my understanding that Chromium only exists as a Snap package within the Ubuntu ecosystem. This subsequently gave me the idea to install Brave as a snap, even though the website says that the version available from the repositories is better maintained. Using the Brave Snap works (although I can see that the settings are not as robust as what was in the repo version).

So unless you see something I don’t, it appears we have A solution, though not necessarily THE solution.

OK. I suspect it has something to do with the NSS library but it appears to be ‘finding’ it based on your ldd output.

I am glad the Snap package works for you. This suggests that something ‘different’ is done when packaging it that way that for whatever reason, obviously works on your system. Not sure what that difference is – maybe whoever is responsible for packaging it could provide some insight.

Another possibility is that the certificates on the system are either out of date, or have been trashed somehow. Typically you’d get system cert updates from the distribution, so I’m not sure how that could happen if you’ve been applying updates, unless it’s an older version that is no longer supported so they don’t provide updates anymore.

Just for the record, I have the exact same problem. When I launch with the -v switch, I also get the message] Device registration failed with fatal error after the NSS error. It’s been like this for ages but I’ve only just got around to investigating. I’m running Mint 21 with Cinnamon desktop.
I will try with Chromium, but Chrome is not allowed near my system!!

Just tried Chromium, it launches instantly.

And finally, I did a complete removal of Brave and reinstalled, and now it seems fine.Brave launches but nothing happens - #11 by chrisp666

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.