Brave keeps the "Cast" option enabled no matter what I do

Description of the issue: Brave is showing me the option to Cast to my TV no matter what I do to disable it.
How can this issue be reproduced?

  1. Launch Brave
  2. Observe that the Cast button in the hamburger menu is present and detecting my TV
  3. Disable the Media Router extension in an attempt to disable it
  4. Observe that the Cast button still exists and still detects my TV
  5. Go to any website and observe that the Cast button still exists and offers to Cast my current web page to my TV
  6. Close Brave and launch it again
  7. Notice that the Cast option still exists and is detecting my TV even though the Media Router is disabled

Expected result: Cast option should be disabled when the Media Router extension is disabled.

Brave Version( check About Brave): Version 1.29.81 Chromium: 93.0.4577.82 (Official Build) (64-bit)

Additional Information: I have tried everything I can think of including disabling all the media/cast related flags in brave://flags, reinstalling Brave after wiping it from the system completely, but the Cast button is still enabled and I still get a pop up on any Youtube video I visit in Brave to stream to my TV. This issue only started happening in the past few weeks and seeing the cast still functioning even though Media router is disabled is really causing me issues. Am I doing something wrong here?

The issue has been acknowledged by developers, there is already a pull request that will fix the issue.

1 Like