Brave keeps logging me out of all accounts

On Chrome, Firefox, & Safari I never have this issue. On Brave if I refresh any logged in account page such as my WordPress admin, it logs me out.

I had to type this post in Firefox because the Brave community page logged me out before I could post it in the Brave browser.

Brave Settings:
• I added my website admin URL to “sites that can always use cookies”
• General settings: allow all cookies
• Turned Brave shield off for my WordPress admin page.
• Clear browsing data on exit: nothing checked

I have made Brave settings as un-secure as possible and no matter what I get logged out of any site when I refresh.

I see lots of posts about this. I tried all the steps, as mentioned above. Anyone see something I missed?

Also, I wish all the previous posts allowed more comments so we could keep these issues in one thread, instead of creating new threads about the same thing.

Hi

Try the following (for Windows):

  1. Disable VPN if you use one.
  2. Disable ‘use secure dns’ in Brave browser.
    3 Disable ‘Fingerprinting’ in Brave browser.
  3. If you are usind a secure dns, try using your internet provider dns, or use google dns 8.8.8.8, 8.8.4.4
  4. Flush dns, and restart machine

Hey friend, thanks for the reply.

I’m on Mac.

  1. No VPN enabled.
  2. I disabled “use secure dns” and this seems to have done the trick. I now stay logged into my accounts.
    3 & 4. Didn’t try these.

Thank you so much for suggesting this. I never would have guessed. I’ll reply back if I encounter the issue again.

Cheers!

1 Like