Brave isn't working anymore since last dev update


#1

Hi !

Well it’s all in the title. Brave made an update today (a dev one) and it can’t reopen anymore. When I click on it, a Brave process appears on the task manager and almost instantly disappears.

I’ll try reinstall it, but if I reinstall the actual dev client, it will not reopen, so I’ll reinstall a previous version


#2

Well. I launched the setup.exe and everything works now


#3

I am having the same exact issue, only I don’t know how to fix it.
It still will not work for me.

EDIT: After redownloading the installer and running the setup, Brave started to work for me again, so far all is good. :+1:

EDIT 2: I am not sure if there are just quick consecutive updates, or if the latest one simply isn’t ‘taking’, as it were. Whenever Brave does try to update, usually every time I close the browser, it breaks again and the only way to get the browser running again is to run the installer all over again.

EDIT 3: Also, for some reason, Brave won’t export my bookmarks, so I am worried about losing those if I have to reinstall or something like that.

EDIT 4: Reinstalled the browser, and it was working fine until the update notification popped up. So, once again, after the browser closes, it updates and then stops working for me. For now, I’ll just leave it uninstalled and save my data from the Roaming Appdata folder…


#4

Mine froze up, would not even let me install the newest update, so I had to shut down the computer. Tried to see if I could repair install, Brave was totally deleted! Everything gone. Downloaded the software again and all of my tabs that were opened popped back up, like it was never gone! What a glitch!

Update #1 The update button popped up again, went to install, once closed, Brave no longer exists on my computer. Reinstalled again and it is back. Not closing or updating until Brave can get this mess fixed.


#5

If you are windows and updated to preview 0.18.34 then its an issue with the preview build. Issue logged and should be fixed soon
https://github.com/brave/browser-laptop/issues/10943


Last update doesn't seem to be working
#6

Hi Everyone,

Manually Updates Fix

Help >>> About Brave >>> click release notes >>> Change the version number and add the latest version of brave in the github releases url and download it. Same problem on this post that is close at Browser window disappears at launch after latest update.

*Note to Software people can you fix the update button so the download dose not disappears at launch after-latest. thanks


#7

I refuse to use Windows 10, I am using Windows 7 Professional. Still acting up but hanging in there.


#8

@TimeTraveler It wasnt specific to Windows 10 but Windows in general. The issue has been fixed and new release is in place. You can upgrade to 0.18.36 now.


#9