Brave "isn't responding" on certain websites


#1

Moto G3
Android 5.1.1
Brave 1.0.30

The first site I noticed the crash/hang was http://ace.mu.nu

However, it is inconsistent. Sometimes it works fine and others, it loads about 3/4 of the way and (especially if I start scrolling down) then stalls and the “Brave isn’t responding. Do you want to close it?” message pops up with the option to report, wait or ok (to close Brave). Today, the site stalled. Once it fully loads, however, it works fine, even if I reload it, until I close the tab and close Brave by swiping it off the recent app list (upon a new Brave session and page load the problem comes back).
Also, I noticed going to http://hooktube.com and trying to load a video seems more consistent in stalling Brave (going straight to youtube to view videos works fine, however). There are other sites I’ve experienced it on but can’t remember them right now. Maybe embeded stuff causes an issue???

When I’ve selected wait sometimes it works (after a while and usually having to hit “wait” a few more times as the ‘ins’t responding’ message will pop up again) other times, the device locks up and screen goes blank for a while (the phone will respond after a while and then I close out brave without the page loading). When I launch the Brave app it will try to load the tab/page again so I have to quickly close the tab otherwise things will lock up agian.

Scripts are allowed in shield settings (turning off all shields doesn’t seem to help either). I also checked my “Running” apps in Android settings and didn’t see any overload.

Any ideas? Is it a known issue w/ Brave (I searched and didn’t see anthing here)? Is it an Android/Phone system/conflicting app issue (if so, how would I figure this out)?

Thanks!

Addendum: Tried loading a video on a local news station and it won’t load so I tried going to a national site: http://video.foxnews.com. I turned off all Shields and the video wouldn’t load, when I tried to scroll down a bit, things lagged a bit but didn’t error out (video never loaded).


#2

Hi @xtend

Regarding the issue you reported with ‘Brave isn’t responding’, do you see similar behavior with any other browsers on your phone for this site? Also, is this in an incognito tab or a normal one?

Regarding the embedded video issue you mentioned, we do have an issue open with some comments noting that embedded videos present an issue:
https://github.com/brave/browser-android-tabs/issues/116

Thanks,
Lauren


#3

@LaurenWags Hmm. I only had Brave on the device but put Firefox on for testing:

The ace site loaded fine (although it did take longer to load than Brave). The hooktube site took a while to load, poped up a firefox warning about firefox not responding and then did fully load and was able to play a video. Could it be the way the sites are configured that it’s creating lags in mobile browsers (if so, firefox seems to handle it better than Brave)?

I didn’t use an incognito window in Brave when experiencing the issue.

Thanks for the tip on the videos. I’ve also seen the error on missing codecs (I got the missing HTML5 or something like that error when I tried to play certain youtube videos).


#4

@LaurenWags Do you have any other suggestions? The issue has cropped up on a few other sites. It all appears to be related to a long delay in loading scripts or some component of a site as each time the ‘load bar’ gets 3/4 of the way across and then things hang. If I wait long enough, the site does load - ie Brave doesn’t appear to be crashing per se, it maybe just taking a long time to deal w/ the script(s) and if I try to scroll down/up on the partially loaded page, the “isn’t responding” message pops up but hitting “wait” and giving it a minute or two usually allows the page to fully load. Again, the issue is inconsistent, sometimes the sites load fine and other times, there’s a lag.

Any ideas?


#5

Still trouble shooting. I ran into same problem on another site: fox13now.com (specifically tested on: http://fox13now.com/2017/09/23/blooper-when-you-think-the-camera-cant-see-you-but-it-can/). Things loaded fine until I tried playing the video, then I got the “isn’t responding error”. Tried in on Firefox (android) and Firefox crashed (firefox closed w/o even an error message).

Thus, may be an issue w/ phone. Any one have ideas?
Anyone run into this before w/ their android device? Could it be a setting…speed of internet connection (this was on wifi)…some missing update to phone’s media processing…??


#6

Looping in some other team members for their thoughts.

Any suggestions, @samartnik @Alexey @Serg ?

Thanks,
Lauren


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.