Brave is out of Date

Windows 10 64 bit. The Brave icon in the upper right (red circle, white arrow) is red and tells me that Brave is out of date. If I click on it I get a notice to reinstall Brave and that link takes me to a website to install Chrome. When I click on “About Brave” the result is that Brave is up to date and: Version 0.60.47 Chromium: 72.0.3626.119. I don’t know if that is the latest version but I have tried to install the latest version of Brave and get the error message: "The installer failed to uncompress archive. Please download Brave again " Same result several times.

1 Like

Latest version is - Version 0.64.76 Chromium: 74.0.3729.157 (Official Build) (64-bit)

If you are uninstalling and reinstalling, dont forget to backup your wallet keys.

I don’t think it’ll work on him.

Could you post the opening link?

Brave is based on Chromium, and that means there are similarities between Google Chrome and Brave. Could you enter the error message (“chrome The installer failed to uncompress […]”) into Google and try the different solutions?

Please also remember to use the official Brave page for a new installation (

This topic was automatically closed after 30 days. New replies are no longer allowed.