Brave is opening all email links in gmail despite the default application being Thunderbird


Description of the issue:
How can this issue be reproduced?

  1. Every time I click on an email link it opens gmail. I’m unable to find the handlers section in settings to remove this.
  2. I’m using Manjaro Gnome and my default email is Thunderbird in settings

Expected result: Open Thunderbird

Brave Version( check About Brave): 88.0.4324.152

Additional Information: I’m running brave beta through pacman rather than through pamac since pamac won’t install pepper flash. But 88 is the most recent available on manjaro even though 89 is on Brave’s site.

Hi @bkarlan,
Can you try going to brave://settings/handlers and seeing if you can remove Gmail?

Ok that fixed that problem. Just FYI, handlers cannot be found in Settings. I went back one menu just to see why I hadn’t found this before and it’s not there as an option. So the only way to access settings is via this url brave://settings/handlers that you gave me.

1 Like

To get to handlers via settings:
Go to Settings → Privacy and security (under Additional settings) → Site and shields settings → Additional permissions (under Permissions) → and you’ll see Handlers

1 Like