Brave is not allowing Truenas Scale Dragonfish to open built in Netdata redirect


Brave is not allowing the built in Netdata redirect link from the UI in Truenas Scale Dragonfish, it just reloads the Truenas scale UI. Tried to replicate in MS Edge and it works without issue, it opens a new tab and I am presented with the Netdata UI. Turned off shields and the problem persists. Allowed pop-ups in site specific settings and it worked once but then presented a credential pop-up, inputting Truenas UI username and password does nothing. After a refresh or closing the browser window it continues its previous behavior and just reloads the Truenas scale UI. If I add /netdata to the URL/ip address in a new tab it just presents a blank white page and presents the credential pop-up/dialogue box.

TrueNAS Scale Dragonfish-24.04.0

Brave V1.65.126

1 Like

I confirm the same behaviour, and tried a similar approach; turning shields down, allowing pop-ups, allowing javascript, etc… No luck…

In Firefox it works flawlessly.

1 Like

Bump, still looking for a fix for this issue.

Looks like the issue has been resolved. I will wait a few days to ensure it is consistent. I did not make any changes with Brave nor Truenas Scale. I just tried to see if I could get the port for Netdata and when I clicked on the icon within Truenas the redirect worked perfectly.

Looks like the issue is resolved. Try now.

Disregard the above. It worked until I closed the browser window. Issue persists.