Brave is Forgetting Favicons

Brave is forgetting my favicons every day and going back to the generic globe symbol. Clicking a globe will go to the site and renew the favicon, but the next day they’ll be generic globes again.

Description of the issue:
How can this issue be reproduced?

  1. Have bookmarks displayed.
  2. Use Brave for more than a day.

Expected result:
Brave should remember the favicons for bookmarks and display them. This used to work.

Brave Version( check About Brave):
Version 1.10.93 Chromium: 83.0.4103.106 (Official Build) (64-bit)]

Additional Information:


Please address it to Web and compatibility but first ,start from Support and Troubleshooting.

Thank you. My issue applies to the Brave Desktop browser’s missing favicons for all sites I have bookmarked. The Web Compatibility category says it is for issues regarding specific web sites. I believe my question is in the correct category.

1 Like

I do believe so as long as you are talking about Brave issues!

I am. And for anyone with Brave who might be following this, I just launched Brave for the first time this morning, saw the favicons that I expected to see for about five seconds, then watched them all turn into generic globes.

I believe the culprit is Sync. I had re-enabled it on my desktop computers via the brave://flags page. I have reset it to Default and will see if the problem goes away.

Hi @BruceS,
Please do let us know if Sync was the culprit.

Yes, Sync was the culprit.

Do you know when the new, stable version of Sync will be rolled out?

Sync v2 is currently available on our Nightly build - if you would want to try that. It will eventually be uplifted to the Release version.

I will try that. Thanks!

1 Like

Hi all.

@BruceS, unfortunately, I don’t think sync has anything to do with this. I am constantly losing my icons. I have Brave on one device only, with sync disabled.

If you find the solution, I hope you reply here. I’d like to continue using Brave, but the constant issues are moving me back to Firefox.

Yesterday I installed Brave Nightly on my two desktops and tried to set up a new Sync chain, but the Sync Chain Code generated by one desktop was not accepted as valid by the other desktop. I tried it both ways. So I’ll stick with the unSynced official build for now and let you work those bugs out.

That’s odd. Removing Sync did work for me. Sounds like there’s more than one issue regarding icons. It is frustrating.

Thanks, BruceS! I’ll double-check and make sure I don’t have sync on. Also, I am 99% sure I have Brave on only one device but have had it on three. I’ll make sure it still isn’t lurking on my old phone or something.

I can verify the loss of favicons seems to be related to the Sync feature. I’ve got 1.10.97 installed on two Win 10 machines. As soon as I enabled sync on both of them I lost the favicons. Even once the favicons are gone if I click a site the favicon is refreshed in the bookmarks, but it disappears again sometime later. I don’t know exactly when it disappears but they aren’t staying with sync enabled. I’m turning off sync today and we’ll see what happens, but this issue definitely happened right after I enabled sync.

***7/16/2020 - Update - I disabled Brave sync on both machines, reloaded all the favicons (which was kind of a pain) and now the favicons are sticking as expected. So it’s certainly sync causing lost favicons.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.