Brave is Blocking evrything, not authentificating SSL


Brave is great but now is giving us some problems, because is not loading all the sites as it should be done.

Well authenticated sites are being blocked even extension from the very Ghrome web Store are being blocked.

After trying cleaning cache, seach history, disabling firewall and everything posible from user side is not working well.
you can see the pic I shared, even oracle is being blocked not only sites with a week SSL.


What I see is something about the SSL authentication , in some cases

the main url domain will work fine but not for the entire site…

Im ready to leave brave if this persist today, I have lost enough time .

Any quick fix till the issue is fixed ?

There are four things you didn’t mention and thus I want to ask if you tried:

  • Disabling Shields?

  • Opening in a private window?

  • Creating a new browser profile?

  • Installing and testing on Brave Beta or Brave Nightly?

Oh, and @Leviathan, it would be nice if you would answer which version of Brave you’re using as well as which OS? Please give specific versions.

To be honest, I think this is just a local issue for you. I’ve not seen anyone else with issues and I’m able to access the sites myself with no problems.

  • Disabling Shields? Yes I did
  • Opening in a private window? Yes I did
  • Creating a new browser profile? I haven’t tried this yet,
  • I am not sure if this is only about my side because using fox or chrome everything works fine,
    I use manjaro Linux …
    Brave Browser
    The last update was run 2 days ago ! [
    Version 1.67.123 Chromium: 126.0.6478.126 (Official Build) (64-bit)

– I have just removed all dependencies and config data, reinstalled again and the issue is not resolved, the only thing i can see it that some SSL Sites are being well authenticated, — this is a very last issue, I think I’m the first one reporting but there will be more,! —