Brave iOS: New Tabs Not Blocking Cosmetics

Description of the issue:

If a website opens a link in a new tab, the website is not initially filtered from cosmetic ads. If I refresh the page, the blank ad spaces and social icons are gone. This is happening for every website that automatically opens in a tab. If I go to the website directly, it works fine.

How can this issue be reproduced?

  1. Go to www.revolver.news
  2. The links change very quickly but open the one " [Bolsonaro rules out military intervention in Brazil]
  3. The gatewaypundit website will open in a new tab. It will have a blank ad space at the top and show all of the social icons.
  4. Refresh the page, and it will now be blocked as expected.

Expected result:

Ad spaces and social icons should be gone on first view.

Brave Version( check About Brave):

Version 1.46 (22.12.15.19)

Mobile Device details

iPhone 14

Additional Information:

Hello @dbcommunity

Thank you for reaching out and Iā€™m sorry to hear you are going through this. Could you please try installing the Beta or Nightly version of Brave to see if the issue persist on those versions?

Be waiting for your response!

This is for Brave iOS. Is there a nightly version?

Do you feel like it regressed and worked fine on version 1.45.x?

In version 1.45 it was worse. It would happen when going to websites directly. I would have to refresh the page for it to block the cosmetics. With 1.46, it has improved.

1 Like

Thanks we will check it out

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.