Brave Instantly Crashing At Startup on Windows 10

Brave Instantly Crashing At Startup on Windows 10

Brave instantly crashes when trying to open the application. The problem is my fault. I was trying to get sync between my android phone and my windows 10 computer working. I went to brave://flags on my windows 10 computer and activated the sync function. Immediately after doing so my Brave browser crashed. I cannot go back and undo this action because Brave always instantly crashes when trying to open it. I tried to do a Windows 10 system restore with no luck. I also tried to uninstall and then reinstall the Brave Application which did not work.

I do not know what version of Brave I currently have because I cannot check due to the application crashing. It should be the latest brave version because I tried to reinstall the program to fix my problem.

Can you try the following:

  1. Find the shortcut you use to open Brave, Right-click --> Properties
  2. In the Target field, add --disable-brave-sync to the end of the text string.
  3. Apply --> OK then launch Brave.

Thank you for the reply, much appreciated!

In the target field I have listed: “C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe”

I have tried:
“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe–disable-brave-sync”

“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe\disablebravesync”

“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe”–disable-brave-sync

When i click “Apply” I get the error message: “The name ‘C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe–disable-brave-sync’ specified in the Target box is not valid. Make sure the path and file name are correct.”

Am I doing something wrong?

Yes. Apologize for not being clear.

"C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe --disable-brave-sync"

There should be a single space before --

I tried your suggested fix. Unfortunately, it did not work.

When I click “Apply” I still get the error message: The name ‘C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe -–disable-brave-sync’ specified in the Target box is not valid. Make sure the path and file name are correct.”

Unfortunately, I have not found a fix to the mistake I made.

I tried to uninstall Brave and reinstall and the problem persisted (kept getting instant crashes). How do I uninstall so that everything is deleted and I can start fresh?

Would it work if I used an uninstaller, like Revo Uninstaller?

Apologize for late response @CookieMonster. I thought I’ve send the reply, but it’s still on draft. :pensive:

So, the correct one is "C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe" --disable-brave-sync

Make sure you add it on Target field and not Start in field

Hi, sorry to piggyback off this thread but I’m having the exact same issue as CookieMonster. I got a new phone yesterday and tried to sync my browsers this morning by enabling sync through brave://flags and ended up with the same issue.

I was able to put in the " --disable-brave-sync" tag at the end of the “Target” field and it allowed me to change it but it still crashes upon opening.

I’m having the same problem on Windows 10.

This problem happened after updating to latest version of Brave v1.7.98. After restarting Brave, I am not able to use Brave anymore.

Every time I open Brave, it starts but immediately freeze. And Windows 10 Task Manager shows high CPU usage from Brave.

I’ve tried --disable-brave-sync but it still crashes.

Thank-you Eljuno!

My problem was fixed after doing: “C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe” --disable-brave-sync.

The program stopped instantly crashing and I was able to go back to brave://flags and deactivate the sync function.


1 Like

Did you open Brave using that shortcut @scroft ? The one that have the flag in Target field.

Glad to know it’s solved for you @CookieMonster.

As a quick update in case you never heard about it, Brave Sync is in priority. No ETA, but the team is working on it ASAP.

Thanks for your patience and apologize for any inconveniences.

Did not work for me. This did.

In File Explorer, go to directory:
C:\Users\[your user name]\AppData\Local\BraveSoftware\Brave-Browser\User Data

Replace [your user name] with your Windows user id. AppData is probably hidden, so you need to turn on view hidden files - not view system files.

Look for the file named “Local State”
Make a back up copy in case this does not work for you.

Edit the file. It is a text file.
Look for something like this in the file:


I removed <<<“brave-sync@1”,>>> saved the file and exited. Brave started up for me.

If it does not work, restore the back up and wait for another solution.

EDIT-fixed original missing backslash after Users and added additonal explanation.

I tried searching for the directory but there wasn’t an AppData folder in my C:/Users folder. I just checked Brave again and it let me open the browser finally so I disabled Brave Sync so hopefully that will fix the problem.

I tried syncing again before disabling but my browser shut down after 30 seconds so I decided to not mess around with it and just leave the sync off for now.

Thanks for the reply, it didn’t help me but hopefully it can help someone in the future.

1 Like

Glad it’s working for you. Mine just instantly crashed, even after reinstalling and trying the command line switch.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.