Brave insanely slow

Hey guys,

I’ve been using Brave on my phone and decided to also use it on my desktop. It is a laptop with an 4700H with internal graphics and an GTX2060.
While connecting via RDP I have to disable the Radeon GPU. Why? Because Software that I’m working with does not want to boot otherwise.
But if I disable the internal Radeon GPU Brave becomes to slow to work with.
Is there a fix or anything I can do? If not I’ll have to switch back to using another browser.

Regards
Phill