Brave immediate crash on Catalina

On Catalina v10.15.6, running on a mac mini mid-2011 (overrode catalina install check to make it work)
Brave is latest LAT340

Start app, within a few seconds get a crash. This is the dump sent to Apple. Any users with similar behaviour ?

Process: Brave Browser [78251]
Path: /Applications/Brave Browser
Identifier: com.brave.Browser
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Brave Browser [78251]
User ID: 501

Date/Time: 2020-10-02 23:05:01.209 +0100
OS Version: Mac OS X 10.15.6 (19G2006)
Report Version: 12
Anonymous UUID: 8C1DCD39-52B1-A025-C217-441E7AB68953

Sleep/Wake UUID: 4D68AE5C-BF94-4761-A05C-C6577E481DD4

Time Awake Since Boot: 890000 seconds
Time Since Wake: 5900 seconds

System Integrity Protection: disabled

Crashed Thread: 0

Exception Type: EXC_CRASH (Code Signature Invalid)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: Namespace CODESIGNING, Code 0x1

kernel messages:

VM Regions Near 0 (cr2):
__TEXT 000000010ec06000-000000010ec2f000 [ 164K] r-x/r-x SM=COW

Thread 0 Crashed:
0 ??? 0x0000000115563000 _dyld_start + 0

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x0000000000000000 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x0000000000000000 rsi: 0x0000000000000000 rbp: 0x0000000000000000 rsp: 0x00007ffee0ff9c40
r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
rip: 0x0000000115563000 rfl: 0x0000000000000200 cr2: 0x0000000000000000

Logical CPU: 0
Error Code: 0x00000000
Trap Number: 0

Binary Images:
0x10ec06000 - 0x10ec2efff +??? (0) (null)
0x115562000 - 0x1155f3f47 +??? (750.6) <34A11073-9E4C-38C3-9293-7D566ABAE8B6> (null)

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 722793
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=1000K resident=0K(0%) swapped_out_or_unallocated=1000K(100%)
Writable regions: Total=8408K written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=8408K(100%)

                            VIRTUAL   REGION 

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
Stack 8192K 1
__DATA 232K 4
__TEXT 748K 2
shared memory 8K 2
=========== ======= =======
TOTAL 65.2M 13

Model: Macmini5,1, BootROM, 2 processors, Dual-Core Intel Core i5, 2.3 GHz, 8 GB, SMC 1.76f0
Graphics: kHW_IntelHD3000Item, Intel HD Graphics 3000, spdisplays_builtin
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1333 MHz, 0x859B, 0x435435313236344243313333392E4D313646
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1333 MHz, 0x859B, 0x435435313236344243313333392E4D313646
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xE4), Broadcom BCM43xx 1.0 (
Bluetooth: Version 7.0.6f7, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: Samsung SSD 860 EVO 250GB, 250.06 GB
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Apple USB SuperDrive
USB Device: Backup+ SL
USB Device: IR Receiver
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: Mac mini, Apple Inc., 22.2

Can you try launching the browser with Hardware Acceleration disabled? You can do this by launching the browser from the Terminal:

Open the Terminal and enter this command:

open -a "Brave" --args --disable-gpu

Thanks for coming back so quick.

The command line failed with the following error:
LSOpenURLsWithRole() failed for the application /Applications/Brave with error -10810.

Any use ?

for info - its the same error from the command line with/without args

Can you try running this command with sudo in the front? Full command should then be

sudo open -a "Brave" --args --disable-gpu

done - same error :frowning_face:

Guess what - issue now fixed.
There was a Library Patch to apply (via Patch Updater) to disable Library Validations for Catalina on unsupported Macs.
Version 4 to be precise.
This has been put on and bingo - Brave now starts up ok.