Brave history size limit or bug? Url/Search bar randomly not showing previously accessed sites

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Description of the issue:
How can this issue be reproduced?

1.Use Brave for a while;
2.Keep using;
3. Start typing a site name or a term for that siteś title that you know you accessed various times in the past;

Expected result:
To have it suggest based on what is in your history.
Brave Version( check About Brave):
Versão 1.50.114 Chromium: 112.0.5615.49 (Versão oficial) unknown 64 bits
](https://brave.com/latest/)
Already happened previously with older versions.

Additional Information:
I already happened with various previous versions, but it seems to be getting worse. I accessed a site last month. Tried to access it today and it wasn’t suggested/completed in the URL bar. Not by site name not by the term like would be in the title.
Previously I used RPM version, now I use Flatpak.

Coukd you go in settings and search for autocomplete URL or some similar settings?
Sorry, don’t have a PC on me right now so can’t exactly tell you where the settings are. I’ll reply once I have a windows device with me.

1 Like

I’ve had this same problem for a while too. Probably since the start but I can’t recall. I have these options enabled

  • Always show full URLs
  • Show autocomplete suggestions in address bar
    -Top sites
    -Browsing History
    -Bookmarks

It only really properly works for sites I’ve visited a heavy amount of times. If I’ve visited a site and can’t recall its spelling but only visited it a few times before, it won’t pop up.

1 Like

Hello
Everything in the suggestions is enabled.

Everything in the suggestions is enabled, but the Always show full URLs. Would it make any difference in this specific issue?

It seems to be a sporadic thing. One example for me: I type in “squid” in the address bar, and it only shows 1/9 of the results I have in my history when I did a search for “squid”. Recently I typed in 3 letters for another site and it auto-completed this time around. However, I suspect it’s because I visited that site between my previous post and now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.