Brave has wiped my metamask wallet saying it was corrupted and now I can not access the certain adress that has all my tokens!

Exactly the same thing has happend to me and ive lost too, the extension dissappeared and ive lost access to my metamask too, tried finding the data needed to get my secret recovery phrase and thats corrupt or encrypted. There must be a bug doing this on brave browser :frowning:

You probably need to go open a support request in the Browser Support/Wallet category. Just create a new topic in that category, follow the instructions, and make sure you use the template when creating your message.

Also, there are several topics in that category that you can look at that might be similar to yours and can help you troubleshoot your issue. Good luck.

@charliebond you’ll need to try to get in touch with @brian as he tends to know more on what’s going on with that tier of stuff I do believe. Until you can get in touch with him and try to figure it out, I also want to refer you to a post I’m linking below where they kind of covered some of it. I am hoping it might help you, but not sure since I never messed with that stuff much.

1 Like

Thanks very much for your reply! Yes I’ve already tried to access it with a computer technician but the actual wallet I was using wasn’t backed up properly by the seed phrase as it was an imported wallet. Much to my disbelief if you have imported a wallet into your current metamask it doesn’t show up when re installing. Maybe obvious to some , but when your a newbie this stuff is hard to understand .

My technician has now restored my computer back to before brave wiped the wallet as corrupted . So we now have the correct file even though its marked as corrupted we will now try to open it by repairing it or though the vault decryptor.

At least we have the actual correct wallet !

I think it’s 50/50

/
Thanks for reply . I’ll let you know if I get into it !

Cheers

Could you confirm if the wallet you recovered has the same seed phrase you have backed up? I would be surprised if MetaMask produced different addresses with the same seed!

I’m not sure why the extension was corrupted, perhaps something like a corrupted file that caused it.

1 Like

I haven’t recovered anything yet.

Unfortunately brave did an auto update last week and we traced the metamask being flagged as corrupted from then , so was my solana phantom wallet .

The account I was using was not backed up as I did not know imported accounts would not restore under the seed phrase of the wallet in use.

After the restore the metamask file would not open as it was before and it was still asking to be reset.

So far the account is still lost.

A very expensive lesson and lots of hard work down the drain at the moment.

When you can see your wallet on etherscan full of all your tokens. It’s the worsed.

Makes me think twice about decentralised finances and trading.

So much more to go wrong .

1 Like

If you think this was related to the 1.35.x update checking new things for corrupted extensions, you could perhaps try loading those files with 1.34.x. All old browsers are available here https://github.com/brave/brave-browser/releases but you will have to scroll back some pages to get the 1.34.x releases. Please advise on progress.

1 Like

Ive had the exact same problem! ive found the log and .ldb files but they seem to be corrput also! > unable to find the keywords necessary to restore my account via metamasks decryptor

There is a repair extensions button in brave://extensions if you want to try using it. I have not tested this though so I don’t know if it erases any local extension data. Just make sure you have a backup of the profile directory. You can get the profile directory path from brave://version/

If you backup that directory, please make sure Brave is closed while backing it up.

Didnt help solve my problem, something needs to be done about this. Spoke to several people that have lost thousands of dollars bcus of this flaw in brave browser. No real support either.

What happened when you pressed Repair?

1 Like

It reset the wallet overwriting the data from the previous version. So I lost my only possible doorway to the right files.

I just restored a wallet for someone that had 10k in it 2 days ago. His problem sounded exactly like yours. You said it was an imported account that you could not restore? Where did you import that account from?

Hi , I imported it from a mobile metamask which I uninstalled because it was empty . Without backing it up . Pretty much lost I reckon !

So, you probably didn’t save the seed phrase or private key from your mobile. In that case the only other option is to see if you have any .ldb files that were deleted but are still on your HD on your computer. To do that you need a forensic program. There is a free one called Stellar Data Recovery. It allows up to 1GB of data ( your ldb files will be much smaller) When you run it, you have to save the files on a flash drive. Anyway. run it on this folder and save any ldb and log files to your flash. If you can’t make any sense of them ( they may be a little corrupted ), you can send them to me and I will take out the Keyring portion and send it back to you. You can then decrypt it using the Vault Decryptor offline ( provided you remember your password ). Here is the path to do the scan on:

C:\Users(your user name )\AppData\Local\BraveSoftware\Brave-Browser\User Data\Default\Local Extension Settings\nkbih…

Found the lbd files but thwy had been corrupted by brave “corruption” of the extension so there is no data to find tk use the vault decryptor😔

Have you tried seeing if there were any deleted files by doing what I posted above?

Hi mate, tried witv simular siftware with no luck. Will try woth this software this evening. If not as you say am i ok to send it over

If you get any file , email it to me. I’ll look at it to see if there is anything there to recover. It may be corrupted, but if you had enough transactions, they may not be corrupted all in the same place, so I can try to piece together the good parts from each to make one good one.

Thanks, will do! But sent it off to 2 data analyst’s and they both said i dont have any chance in recovering the data, but i wont give up yet