Brave hangs on eftps.gov

Description of the issue:
Attempt to login to eftps.gov to make tax payment hangs.

Exact URL of the website in question:
https://www.eftps.gov/eftps/login/loginInitial

Did the issue present with default Shields settings? (yes/no)
Yes.

Does the site function as expected when Shields are turned off?
No.

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
No.

Does the site work as expected when using Chrome?
Yes.

Brave version (check About Brave):
v1.40.109 Chromium: 103.0.5060.66

What OS are you on?

Can you tell us more detail about the behavior you see? I’m guessing you enter the login info and then it fails to load the next page?

Do you have anything set in brave://adblock ?

Windows 7.
Enter URL with Brave, click on “make a payment”, see page painted, click on EIN field, cursor does not enter EIN box, unable to enter any digits, soon get “page unresponsive”.
Nothing checked in brave://adblock.
Works just fine with Internet Explorer and used to work fine with Chrome until I replace Chrome with Brave.
Thanks for your time.

Hey @FrankNatoli can you test this, add into brave://adblock

eftps.gov##+js(acis, tmx_post_session_params_fixed) Then refresh the eftps.gov page

Slightly better, as in when I click on the EIN field the cursor blinks in the first box. But I cannot enter any digits, and eventually “page unresponsive” pops up. See attached screenshot. Restarted Brave repeatedly after adding your code, no luck.