Brave Grand is not working

Description of the issue:
For a month I am getting this message that I have a grant waiting for me, but when I try to claim it I always get the message: Oops, something is wrong please try again later. But now we are 3 weeks further, have tried several times, but continue to get the same error message.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
I click in below screen on CLAIM
claim
Then I do the bot validation.
After approved not being a bot, I continue and get this message:

Actual Result (gifs and screenshots are welcome!):
See above.

Expected result:
Get the grant.

Reproduces how often:
Think about 7 times?

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10
BRAVE: Version 0.68.132 Chromium: 76.0.3809.132 (Official Build) (64-bit)

Additional Information:

1 Like

also see two monthly this, no bats no can send on verified publsher no fun :upside_down_face:

Dear moderator, is there already a solution for this? It keep popping up, and is annoying to have constantly an alert, but no way to accept the grand.

1 Like

yes is in actuality question.

Where can I find that?

I am having the same problem. Only once have I been able to prove that I am human. Very frustrating. I have changed my displayed and zoomed all the way in. Please fix.