Brave freezes on Upload/Add attachment button

Brave will freeze in the current Window if I select Upload or Add Attachment, and usual browser behavior will Pop-up the Windows Explorer Window to select file but nothing will happen. I have this issue on at least two of my Windows Computers, all under the same Sync Account.

Steps to Reproduce

  1. In Gmail, I click on “Add Attachment” button
  2. Any Website where I click on “Upload” button
  3. In “Add Image or File” menu, I select “From my device” and click on “Choose Files” button

Actual Result (gifs and screenshots are welcome!):
Brave freezes. I must terminate the process in Windows Task Manager. I re-open Brave browser and attempt above steps again. Brave freezes again.

Expected result:
When I click the button in Firefox/Chrome Edge browsers (also installed on my machine), “Open” window pop-up appears asking me to locate the file to upload.

Reproduces how often:
All the time.

Operating System and Brave Version
Windows 10 (Dell XPS 7590)
Version 1.31.88 Chromium: 95.0.4638.69 (Official Build) (64-bit)
Eset Internet Security Antivirus

Steps Tried to Fix
Cleared the Site Data for Gmail
Disabled all Extensions
Turned off Shields for Sites I need to upload something

Additional Information
This problem is only present within Brave none of my other Browsers I have installed have this problem. Its odd that is it happening across my devices even with Extensions disabled.

Saw previous post about this in the community and their solution didnt work for me concerning uninstalling Dropbox as I dont have it installed.

Checked the Safety Check within Brave no issues there.

1 Like

Do you have ESET on both of the affected computers?

Can you try disabling it temporarily and see if anything changes?

Yes I forgot to mention that I did try disabling ESET and the results were the same.

1 Like

Does the issue occur if you create a new profile? It won’t trash your existing profile, just create a new one for you to test in.

1 Like

Hi, I can confirm that if I create a new profile I am able to open the add attachment in Gmail.

So does this mean my main profile is corrupt somehow?

Unclear… it certainly means that something is ‘wrong’ in the profile, but I don’t know if it’s corrupt in some way that is irrecoverable.

What about a Private window in your original profile? Same thing?

Yep, exact same behavior.

Does this still happen on 1.31.91?

Also found a strange case where someone seemingly resolved a similar issue by uninstalling Dropbox, not sure if that applies here.

It does seem that the new update to 1.31.91 does fix the issue.

In my case I dont have Dropbox installed at all.

Thanks for the changes to Brave that fixed this issue, really appreciate it.

1 Like

Issue came back on Version 1.32.106 :cry:

Sigh. :disappointed:

Well, there is another 1.32.x release due out any day now, I would say within the next few days. Want to pick this back up there if the issue still happens then?

1 Like

Sounds good I’ll keep you posted.

1 Like