Brave forgets EVERYthing after update. Working as intended?

I just ran into this weird behavior again, the first time I dismissed it as an accident, but now I would like to know if this is intentional (e.g. to force users to use the sync feature?)

Any ideas much appreciated!

Description of the issue:

After Brave gets an update through the Linux package manager (eopkg on Solus in this case, but same thing happened on Ubuntu 18.04 earlier) it forgets everything and pretends to be a fresh install. It even removes itself from the dock/favorite programs. It is as if you uninstalled it with purge and made a fresh install.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Install and use Brave, enter passwords, configure Metamask, BAT wallet, etc.etc…
  2. Update Brave
  3. Start from scratch because all your data are GONE.

Actual Result (gifs and screenshots are welcome!):

Fresh install… no need for screenshots.

Expected result:

I would expect my bookmarks, passwords, etc.etc. to survive an update…

Reproduces how often:

At least twice, once on Ubuntu a while back, now again with the very first update that I did on Solus.

Brave Version(about:brave):

Version 0.56.12 Chromium: 70.0.3538.77 (Official Build) unknown (64-bit)

Reproducible on current live release (yes/no):

Additional Information:

Would appreciate hints if this is intentional or not, and if not, how to prevent it from happening in the future. I really like Brave, but I am kinda unwilling to start from scratch after every update.

Definitely not intentional. Also, the most recent release is 0.56.15.
Are you installing via these instructions?

Thanks for the feedback! Yeah, I thought it was probably not intentional, but you never know in this age of forced cloud usage…

Anyways:

I am installing via the packet manager of whatever distro I am using OR use snaps/appimages.
Same goes for updates.
Nothing that the instructions you linked suggest should lead to different results.

In this case eopkg is used, and the packages Solus provides are usually quite recent.
When I had the same problem on Ubuntu earlier this year I THINK I used the snap, but may have been deb/apt, can’t verify that any more since I got rid of Ubuntu completely.

In any case being one or two releases behind should not matter for the update process between version n and n+1

While I am a fairly technical “user” I have little insight in the inner workings of the update process, but it seems that Brave packages tend to tell the package manager to purge the previous version including the user data, preferences dir shows no signs of previous usage after the update.

Which is quite weird and very impractical. :smiley:

P.S.: just searched the forum again with different search terms and found this is not a new issue or abnormal singularity but has been reported by several people (“Brave keeps resetting after every update” etc.). Seems to happen even with the Mac version as well. Did not find any solutions or very accurate error analysis from either users or team. Have never encountered this problem with other browsers and very few other software packages. Would be certainly an improvement if you could pinpoint what in the instructions that Brave packages pass on to the packet manager (or in the Brave code itself) causes this. It is a serious show stopper for using Brave as the primary browser (which I would love to do otherwise).

Hi,

It seems i kinda have the same issue.

Until yersterday (Friday the 14th of december), i was using BRAVE old version (so it seems).

This morning, i had the unpleasant surprise to see it updated itself without any warning and with a totally new Browser version (Version 0.56.12 Chromium: 70.0.3538.77 (Official Build) unknown (64-bit).

I am under Linux Ubuntu 18.04 and had the former BRAVE version installed with a snap package.
So the New BRAVE updated using the snap feature.

The problem is, i have no more bookmarks.

As seen in another Linux related post, i looked for a .config/brave folder hoping to find something in there.

BUT… i have no BRAVE Folder in my .config one.

What should i do to get access to my precious bookmarks, please ?

Cordially

Hi, I think I solved the problem with snap. Worked for me.

  1. Downgrading the snap packet :
    in terminal “sudo snap revert brave”

  2. Launch Brave via icons or entering “brave” in a terminal, you should have everything like before upgrade

  3. Save your Wallet as said here https://support.brave.com/hc/en-us/articles/360018538092-How-do-I-upgrade-Brave-to-the-newest-version-

  4. Close brave

  5. Install via apt in stead of snap following this : https://support.brave.com/hc/en-us/articles/360018666072-Linux-Installing-Brave-from-Terminal-

  6. Launching the new brave
    in terminal type “brave-browser” (if you enter “brave” it’s launching the snap version)

  7. You should now see the “brave_old” in import / export stuff https://support.brave.com/hc/en-us/articles/360019782291-How-do-I-import-or-export-browsing-data-

  8. So import your browsing datas

  9. Recover your wallet https://support.brave.com/hc/en-us/articles/360020673191-How-do-I-back-up-or-Restore-my-Wallet-in-Brave-

For our passwords, I think we are fucked.

EDIT : if you want continue with snap, upgrade snap instead of the 5th step : in terminal " sudo snap refresh brave "

2 Likes

Waou…thx so much, it did work like a charm for me, did exactly the job as i was able to get my hands on ALL my bookmarks (which i NOW saved btw).

Thx again for your very detailed tuto

1 Like

Thank You!

I have to write 20 characters to post, so I’m writing this sentence now.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.