Brave faltering

Description of the issue:

Brave works for a little while maybe 5 minutes, but after this period everything becomes very slow untill eventually nothing wants to load anymore (youtube videos lagg and falter). Even their settings and error logs pages.

How can this issue be reproduced?

I have no clue, some people i know also use brave some of them don’t have this issue some of them do.

Expected result:

Brave loads and works smooth and correctly.

Brave Version( check About Brave):

Versie 1.51.114 Chromium: 113.0.5672.92 (Officiële build) (64-bits)

Additional Information:

  • Windows 11 laptop system, with 32 GB of RAM, rtx 3070, AMD ryzen 5800H, 2 TB of free storage (so i don’t think it’s a performance issue, in task manager are no suspicious activities)
  • Stable internet connection
  • Tried FULLY clearing the browser cache with no result
  • Tried to reset settings
  • Did an uninstall of brave and reinstall of brave
  • Braves error log page and it’s additional support pages won’t even load

@Puncas I’m going to ask you to test some things if you would. Try each step separately, not combined. So like do step 1 and test. If it resolves, you can stop there and let us know. Otherwise, go on to the next step. Essentially I’m giving you a bunch of troubleshooting steps as well as some things which have resolved problems for people before.

It’s a decent amount of steps but doing it so we can rule out a number of issues, but also so Support has more information at their fingertips on how to help you.

  1. Go to brave://settings/system and switch the toggle for Use hardware acceleration when available to the opposite of its current setting. So if it was on, turn it off. Or if you have had it turned off, try it on.

  2. Open in Private Window.

  3. Create a new browser profile, make sure you don’t add any extensions or change settings to it (if this doesn’t change anything, can delete new profile and go back to original)

  4. Go to brave://flags and enable Vulkan. (if doesn’t change anything, can put it back to default)

  5. If you hit Shift + Esc it will open Brave’s Task Manager. Try to see if anything shows high usage. It may help to narrow down what’s going on if it’s a process within Brave that’s causing issues.

  6. Disable any antivirus, internet security, and/or firewall you have.

  7. Install Brave Beta or Brave Nightly to see if the issue replicates.

  8. Test on Chrome if you can, see if it has issues as well.

  9. Perhaps I should have put this up higher on the list, but try to open Windows task manager, which is Ctrl + Alt + DelTask Manager and watch resources there to see if another program or process on your device is using up a lot of CPU/Memory and causing your problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.