Brave fails to update


#1

I have been prompted four times in the past 24 hour to update Brave. The prompt comes from Brave’s auto-update feature. Each time I have hit the UPDATE button, the browser closes and opens again. For some reason, it is not updating, so I’m been prompted every 30 minutes or so to update again. Is there something I can do? Should I delete my current version and download the most current version manually? And, why isn’t the auto-update feature working? Or, is it? See details for current build below. - Thanks

Brave: 0.19.66
rev: 148f5b066d5d0d786bafaf80f396e753d42e0412
Muon: 4.5.9
libchromiumcontent: 62.0.3202.62
V8: 6.2.414.32
Node.js: 7.9.0
Update Channel: Release
OS Platform: Microsoft Windows
OS Release: 6.1.7601
OS Architecture: x64


#2

Hi @mellochord,

It seems you are using preview version. Latest stable version is 0.19.53.
Did you enabled Update to preview releases in Preferences > Advanced?

Preview version is more likely to test the browser before it hit stable release. And from what I see, latest preview release is 0.19.66.


#3

I have checked out preferences, there is nothing concerning a preview release. In all the settings there is no option for a preview release as opposed to stable. My big concern was whether I had done something that was blocking Brave from updating. So, it seems I’m up to date with whatever test release I’m using. Last night it updated to 0.19.67 and I lost my bookmark toolbar. Ah well, all part of the sacrifices we must make to build a better browser. Thanks for the assistance all the same.


#4

Latest preview build available is now 19.67, really helps out the team if you help test preview builds and report to them any bugs you find.


#5

I haven’t been able to update either. I’ve accepted it multiple times, always relaunching the browser. Just keeps prompting me for the new version.

Also, Brave doesn’t use Adobe Flash?


#6

As of yesterday I’m experiencing the same issue on Mac OS:High Sierra.


#7

Hi @njt64, From where do you download Brave? Latest stable release must be 0.19.122. If download from brave.com, you must be have the latest stable.

@njt64, Flash support is opt-in and disabled by default. See steps mentioned here to enable Flash on desktop Flash isn't working / Audio or Video is not working

Hi @msn, mind checking this thread: Updates are available but applying them doesn't work on macOS

Best,
:slight_smile:


#8

Thanks so much @eljuno :slight_smile:

I don’t see the electron folder in Brave’s library? I’m very new to Mac so I could be making a mistake -I navigated library/application support/brave

I’m on Mac using High Sierra


#9

@msn, because I;m not using Mac so I’m not very sure about the folder too. :smiley:

But you also can do manual upgrade. Download the latest version of Brave from Brave website, make sure brave is closed, then you can run the newer installer. This way, Brave will install the latest version.

Hope this can help,
Best.
:slight_smile:


#10

That seems to have worked!

Thanks again @eljuno

::applause::


#11

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.